Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-48450

"java.io.InvalidClassException": org.jenkinsci.plugins.durabletask.BourneShellScript$getOsType

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Not A Defect
    • Component/s: core
    • Environment:
      master: ubuntu 16.04.3 / openjdk version "1.8.0_151"/wildfly 11

      slave: redhat 5.11 / oracle Java(TM) SE Runtime Environment (build 1.8.0_152-b16)

      pipelines plugins, groovy
    • Similar Issues:

      Description

      I have a pipeline job executed on remote slave . It was working fine.
      I don't know what happened, may be a plugins update, but now it makes InvalidClassException:

      Started by user
      XXX
      [Pipeline] node
      Running on X in /data/jenkins/2.32.1/workspace/RH-56-COMPILE-SOFTWARE
      [Pipeline] {
      [Pipeline] stage
      [Pipeline] { (Pré-requis)
      [Pipeline] sh
      [Pipeline] }
      [Pipeline] // stage
      [Pipeline] }
      [Pipeline] // node
      [Pipeline] End of Pipeline
      java.io.InvalidClassException: org.jenkinsci.plugins.durabletask.BourneShellScript$getOsType; local class incompatible: stream classdesc serialVersionUID = 1, local class serialVersionUID = -726330664758628105

      pipeline content:
      ----------------

      parameters {
      string(defaultValue: 'master', description: 'node', name: 'node')
      }

      node("$node") {
      // some block

      parameters {
      string(defaultValue: 'soft1', description: 'software', name: 'software')
      string(defaultValue: '0.0', description: 'software version', name: 'softwareVersion')
      }

      def sources_dir="/data/sources/$software"
      def compile_dir = '/data/compilation'

      stage ('Pré-requis') {
      sh "yum install gcc zlib-devel.x86_64 openssl-devel.x86_64 libtool wget curl unzip"
      }

      stage('Download and untar apache sources') {

      sh "mkdir -p $sources_dir"
      dir ("$sources_dir") {
      def exists = fileExists "$sources_dir/${params.software}-${params.softwareVersion}.tar.gz"

      if (exists) {
      echo 'Fichier existant'
      } else {
      sh "http_proxy=http://proxy-out:3128 wget http://mirrors.ircam.fr/pub/apache//httpd/$\{params.software}-${params.softwareVersion}.tar.gz"
      }

      }

      }

      stage('Compilation') {
      def exists = fileExists "$compile_dir/${params.software}/${params.software}-${params.softwareVersion}"
      if (exists) {
      sh "rm fR $compile_dir/${params.software}/${params.software}${params.softwareVersion}"
      }
      sh "mkdir -p $compile_dir/${params.software}"
      sh "tar C $compile_dir/${params.software}/ -zxvf $sources_dir/${params.software}${params.softwareVersion}.tar.gz"
      dir ("$compile_dir/${params.software}/${params.software}-${params.softwareVersion}") {
      sh "chown -R root:root ."

      }
      }

      }

        Attachments

          Activity

          gquentin Gaétan QUENTIN added a comment -

          ok so it is fixed: the problem is the java version, which is not the same on master and on nodes.

           

          i have replaced openjdk by oracle java package on master, and the problem disappeared.

           

          you can close the issue.

          oleg_nenashev Oleg Nenashev added a comment -

          Thanks for the update!


            People

            • Assignee:
              Unassigned
              Reporter:
              gquentin Gaétan QUENTIN
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: