Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-48637

Loading detached or bundled plugins should enable any dependent plugins that are installed but disabled

    Details

    • Type: Bug
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Component/s: core
    • Labels:
      None
    • Similar Issues:

      Description

      Discovered by Daniel Beck while investigating JENKINS-48604.

      Reproduction

      1. Create a fresh instance of Jenkins 2.85 or older.
      2. Install script-security, and disable it.
      3. Upgrade Jenkins to 2.87+.
      4. Expected Result: command-launcher:1.0 should be installed, and script-security should be enabled. (Maybe a message should be shown to the user that says something like: "script-security has been enabled because of blah...")
      5. Actual Result: The user receives the following error:
      Dec 19, 2017 7:32:33 PM hudson.PluginManager loadDetachedPlugins 
      INFO: Upgraded Jenkins from version 2.84 to version 2.97-SNAPSHOT (private-12/18/2017 21:47 GMT-win2012-cba0b0$). Loaded detached plugins (and dependencies): [command-launcher.hpi] 
      … 
      Dec 19, 2017 7:32:33 PM jenkins.InitReactorRunner$1 onTaskFailed SEVERE: Failed Loading plugin Command Agent Launcher Plugin v1.0 (command-launcher) java.io.IOException: Command Agent Launcher Plugin v1.0 failed to load. 
       - Script Security Plugin is disabled. To fix, enable it.
      

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                dnusbaum Devin Nusbaum
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated: