Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-48894

Plugins cannot depend on Jenkins 2.2+ (Stapler 1.240+) and org.glassfish.hk2:hk2-utils at the same time

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Not A Defect
    • Component/s: core, maven-hpi-plugin
    • Labels:
      None
    • Similar Issues:

      Description

      Steps to reproduce:

      1. Generate the hello world plugin from archetype (version 1.2)
      2. Add the dependency:
      <dependency>
            <groupId>org.glassfish.hk2</groupId>
            <artifactId>hk2-utils</artifactId>
            <version>2.4.0-b12</version>
          </dependency>

      Expected result: Injected test works

      Actual result: Injected test fails with:

      java.lang.NoSuchMethodError: org.jvnet.tiger_types.Types.bind(Ljava/lang/reflect/Type;Ljava/lang/reflect/GenericDeclaration;Ljava/lang/reflect/ParameterizedType;)Ljava/lang/reflect/Type;
      

      This came from investigation of problems related to updating the parent POM in a plugin with jersey dependencies (HOSTING-481 discussion)

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                danielbeck Daniel Beck
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: