Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-4908

SystemDrive and SystemRoot environment variables needs to be set up unnecessary

    Details

    • Type: Patch
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: p4-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      In order to let the perforce client work on windows the SystemDrive and SystemRoot env needs to be
      specified in the perforce config, however these settings can be optained form the hudson java process
      environment variables.

        Attachments

          Issue Links

            Activity

            lkishalmi lkishalmi added a comment -
                • Issue 4909 has been marked as a duplicate of this issue. ***
            lkishalmi lkishalmi added a comment -

            Created an attachment (id=1030)
            Proposed patch

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in hudson
            User: : rpetti
            Path:
            trunk/hudson/plugins/perforce/src/main/java/hudson/plugins/perforce/PerforceSCM.java
            http://fisheye4.cenqua.com/changelog/hudson/?cs=23944
            Log:
            [FIXED JENKINS-4908] applying patch provided by lkishalmi to obtain SystemDrive and SystemRoot from the node environment


              People

              • Assignee:
                Unassigned
                Reporter:
                lkishalmi lkishalmi
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: