Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-49281

slaveConnectTimeout not applying to pipeline jobs

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Incomplete
    • Component/s: kubernetes-plugin
    • Environment:
      Jenkins 2.103 (Docker) running on Debian x64
      Kubernetes-Plugin 1.1.4
      Kubernetes cluster running on ARM
    • Similar Issues:

      Description

      attempted to set slaveConnectTimeout: 1200 through both Global Settings and directly in Pipeline podTemplate. I can confirm that the plugin is getting the value, as when setting the value to string rather than int i receive the expected exception error when running the build.
      The value is not being honoured by Jenkins though, as the slave node connection timeout is still set to 100.
      I need the timeout to be 1200 as my slave on the ARM cluster can take up to 15 minutes to fully connect and register with the master.

        Attachments

          Activity

          Hide
          csanchez Carlos Sanchez added a comment -

          can you provide the logs, specifically the lines around Waiting for agent to connect

          Show
          csanchez Carlos Sanchez added a comment - can you provide the logs, specifically the lines around Waiting for agent to connect

            People

            • Assignee:
              csanchez Carlos Sanchez
              Reporter:
              nichmidd Nick Middleton
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: