Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-49588

java.lang.NullPointerException at hudson.model.Fingerprint.addWithoutSaving(Fingerprint.java:1035)

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Environment:
      Ubuntu
      Jenkins 2.107
    • Similar Issues:
    • Released As:
      Jenkins 2.163

      Description

      I'm not sure what's going on at this point, but I got two warnings about old data for fingerprint and now none of my builds are working.

      java.lang.NullPointerException
      	at hudson.model.Fingerprint.addWithoutSaving(Fingerprint.java:1035)
      	at hudson.model.Fingerprint.add(Fingerprint.java:1030)
      	at hudson.model.Fingerprint.addFor(Fingerprint.java:1023)
      	at com.cloudbees.plugins.credentials.CredentialsProvider.trackAll(CredentialsProvider.java:1457)
      	at com.cloudbees.plugins.credentials.CredentialsProvider.track(CredentialsProvider.java:1421)
      	at hudson.plugins.git.GitSCM.createClient(GitSCM.java:818)
      	at hudson.plugins.git.GitSCM.createClient(GitSCM.java:786)
      	at hudson.plugins.git.GitSCM.checkout(GitSCM.java:1154)
      	at org.jenkinsci.plugins.workflow.steps.scm.SCMStep.checkout(SCMStep.java:113)
      	at org.jenkinsci.plugins.workflow.steps.scm.SCMStep$StepExecutionImpl.run(SCMStep.java:85)
      	at org.jenkinsci.plugins.workflow.steps.scm.SCMStep$StepExecutionImpl.run(SCMStep.java:75)
      	at org.jenkinsci.plugins.workflow.steps.AbstractSynchronousNonBlockingStepExecution$1$1.call(AbstractSynchronousNonBlockingStepExecution.java:47)
      	at hudson.security.ACL.impersonate(ACL.java:290)
      	at org.jenkinsci.plugins.workflow.steps.AbstractSynchronousNonBlockingStepExecution$1.run(AbstractSynchronousNonBlockingStepExecution.java:44)
      	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
      	at java.lang.Thread.run(Thread.java:748)
      Finished: FAILURE
      

      I am using Java version 8.

        Attachments

          Issue Links

            Activity

            torstenreinhard Torsten Reinhard added a comment - - edited

            I had the same issue when loading my pipeline library, Jenkins 2.138.2. It occured after installing "custom-tool" plugin.

            Loading library workflowLibs@master
            Attempting to resolve master from remote references...
             > git --version # timeout=10
            using GIT_SSH to set credentials Bitbucket_Access (ssh://git@git.mycompany.net:port)
             > git ls-remote -h ssh://git@git.mycompany.net:port/scopecom/workflowlibs.git # timeout=10
            Found match: refs/heads/master revision d61d4cd5c6b3383722cc6b47b3d1ef9571803e3f
            java.lang.NullPointerException
             at hudson.model.Fingerprint.addWithoutSaving(Fingerprint.java:1033)
             at hudson.model.Fingerprint.add(Fingerprint.java:1028)
             at hudson.model.Fingerprint.addFor(Fingerprint.java:1021)
             at com.cloudbees.plugins.credentials.CredentialsProvider.trackAll(CredentialsProvider.java:1457)
             at com.cloudbees.plugins.credentials.CredentialsProvider.track(CredentialsProvider.java:1421)
             at hudson.plugins.git.GitSCM.createClient(GitSCM.java:844)
             at hudson.plugins.git.GitSCM.createClient(GitSCM.java:812)
             at hudson.plugins.git.GitSCM.checkout(GitSCM.java:1180)
             at org.jenkinsci.plugins.workflow.steps.scm.SCMStep.checkout(SCMStep.java:120)
             at org.jenkinsci.plugins.workflow.libs.SCMSourceRetriever.doRetrieve(SCMSourceRetriever.java:116)
             at org.jenkinsci.plugins.workflow.libs.SCMSourceRetriever.retrieve(SCMSourceRetriever.java:86)
             at org.jenkinsci.plugins.workflow.libs.LibraryAdder.retrieve(LibraryAdder.java:157)
             at org.jenkinsci.plugins.workflow.libs.LibraryAdder.add(LibraryAdder.java:138)
             at org.jenkinsci.plugins.workflow.libs.LibraryDecorator$1.call(LibraryDecorator.java:125)
             at org.codehaus.groovy.control.CompilationUnit.applyToPrimaryClassNodes(CompilationUnit.java:1065)
             at org.codehaus.groovy.control.CompilationUnit.doPhaseOperation(CompilationUnit.java:603)
             at org.codehaus.groovy.control.CompilationUnit.processPhaseOperations(CompilationUnit.java:581)
             at org.codehaus.groovy.control.CompilationUnit.compile(CompilationUnit.java:558)
             at groovy.lang.GroovyClassLoader.doParseClass(GroovyClassLoader.java:298)
             at groovy.lang.GroovyClassLoader.parseClass(GroovyClassLoader.java:268)
             at groovy.lang.GroovyShell.parseClass(GroovyShell.java:688)
             at groovy.lang.GroovyShell.parse(GroovyShell.java:700) 

            in the /fingerprints directory I found 2 files, one of them seems to be truncated (closing xml tags missing):

            <?xml version='1.1' encoding='UTF-8'?>
            <fingerprint>
              <timestamp>2018-10-19 12:31:24.262 UTC</timestamp>
              <md5sum>1f14c21f4332acaf8c1bad991f7b0f14</md5sum>
              <fileName>Credential id=Bitbucket_Access name=myuser (Bitbucket_Access (ssh://git@git.mycompany.net:port))</fileName>
              <usages>
                <entry>
                  <string>SeedJob-Generator-ofco-TEST4</string>
                  <ranges>1-3</ranges>
                </entry>
            ...
                 <entry>
                  <string>SeedJob-Generator-dcom-aws-prod-preprod</string>
            
            uhsarp Uhsarp Rin added a comment -

            Fixed after stopping the server, deleting the fingerprints folder and restarting the server.

            oleg_nenashev Oleg Nenashev added a comment -

            It is still not clear what is the root cause, but I propose to consider this ticket as resolved by https://github.com/jenkinsci/jenkins/pull/3305 which was released in 2.163 . If somebody sees such issue after the fix, please create a follow-up ticket and assign it to me

            fcojfernandez Francisco Fernández added a comment -

            Issue already fixed in 2.166

            oleg_nenashev Oleg Nenashev added a comment -

            Correction: 2.163


              People

              • Assignee:
                mikecirioli mike cirioli
                Reporter:
                jomega Alexander Trauzzi
              • Votes:
                7 Vote for this issue
                Watchers:
                20 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: