Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-49803

Connection with Testlink-Problem

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Not A Defect
    • Labels:
      None
    • Environment:
      Windows/64 bits-
      Jenkins ver. 2.89.4
      TestLink 1.9.16/ TestLink Plugin 3.13
      jdk1.8.0_161-jre1.8.0_161
      Chrome.
    • Similar Issues:

      Description

      Hi everyone

      After i set the configuration at Jenkins, i tried to Buils Now, although i got this message:

      org.apache.commons.jelly.JellyTagException: jar:file:/C:/Program%20Files%20(x86)/Jenkins/plugins/testlink/WEB-INF/lib/testlink.jar!/hudson/plugins/testlink/TestLinkResult/index.jelly:6:57: <st:include> No page found 'sidepanel.jelly' for class hudson.plugins.testlink.TestLinkResult at org.kohsuke.stapler.jelly.IncludeTag.doTag(IncludeTag.java:124) at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:269) at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95) at org.kohsuke.stapler.jelly.CallTagLibScript$1.run(CallTagLibScript.java:99) at org.apache.commons.jelly.tags.define.InvokeBodyTag.doTag(InvokeBodyTag.java:91) at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:269) at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95) at org.kohsuke.stapler.jelly.ReallyStaticTagLibrary$1.run(ReallyStaticTagLibrary.java:99) at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95) at org.kohsuke.stapler.jelly.ReallyStaticTagLibrary$1.run(ReallyStaticTagLibrary.java:99) at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95) at org.apache.commons.jelly.tags.core.CoreTagLibrary$2.run(CoreTagLibrary.java:105) at org.kohsuke.stapler.jelly.CallTagLibScript.run(CallTagLibScript.java:120) at org.apache.commons.jelly.tags.core.CoreTagLibrary$2.run(CoreTagLibrary.java:105) at org.kohsuke.stapler.jelly.JellyViewScript.run(JellyViewScript.java:95) at org.kohsuke.stapler.jelly.DefaultScriptInvoker.invokeScript(DefaultScriptInvoker.java:63) at org.kohsuke.stapler.jelly.DefaultScriptInvoker.invokeScript(DefaultScriptInvoker.java:53) at org.kohsuke.stapler.jelly.JellyClassTearOff.serveIndexJelly(JellyClassTearOff.java:112) at org.kohsuke.stapler.jelly.JellyFacet.handleIndexRequest(JellyFacet.java:140) at org.kohsuke.stapler.IndexViewDispatcher.dispatch(IndexViewDispatcher.java:30)

      most line in the image.

      It is my first post, sorry if all information is not here,i'll try to see more information in the next.

        Attachments

          Activity

          douglas_velho Douglas Velho added a comment -

          There is an attachment when i try to 'build now' with the configuration on this link https://www.ranorex.com/blog/integrating-ranorex-automation-in-jenkins-continuous-integration-process/

          mstoegerer Markus Stoegerer added a comment -

           Hi Douglas,

          Thank you for reporting this issue. Unfortunately, I am not exactly sure if this is directly related to the Ranorex Execution plugin since the stacktrace does not contain any information about the plugin. 

          Also may I ask you why the parameter global execution path points to the test.exe itself?

          Thank you in advance.

          douglas_velho Douglas Velho added a comment -

          Hi Markus,

          Thank you for answer me.So, global execution path at file "ao_tentar_gerar_build.JPG" point to "TESTE_INTEGRACAO.exe" because it is the file that execution this test from Ranorex.

          The file Jenkins_conn.JPG and Test_link_result.txt are about when i set just TestLink on Jenkins, without Ranorex configuration.

          If you need more information, i can provide.

          mstoegerer Markus Stoegerer added a comment -

          Hi Douglas,

          Thank you for the additional information. After analyzing the issue in more detail I was able to reproduce it even without using the Ranorex Integration plugin.

          Unfortunately, it seems the issue is related to the Testlink integration plugin.

           

          mstoegerer Markus Stoegerer added a comment -

          Not related to the Jenkins integration plugin

          douglas_velho Douglas Velho added a comment -

          Hi Markus, thank you for reply me.

          I'll open another occurrence just with testlink-plugin.

          I was set Ranorex integrate with Test Link, but i cann't they work together.After fix this issue with testlink i'll set Ranorex again.

          Thanks for help.

           

          mrpsycho Yar n added a comment -

          who is author of this plugin?


            People

            • Assignee:
              mstoegerer Markus Stoegerer
              Reporter:
              douglas_velho Douglas Velho
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: