Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-4995

Support windows AMI's in EC2 plugin

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: ec2-plugin
    • Labels:
      None
    • Similar Issues:
    • Released As:
      ec2 plugin 1.24

      Description

      Supporting windows would be really useful: we ship our products on windows as well as Linux, but all our devs run Linux

        Attachments

          Issue Links

            Activity

            batmat Baptiste Mathus added a comment -

            I believe this issue could (or should) actually be closed as Resolved, and new issues be filed about the issues that are still present.

            AFAIU, Francis worked on adding support (see commits linked as a comment in 2014 https://issues.jenkins-ci.org/browse/JENKINS-4995?focusedCommentId=206750&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-206750).

            People have rightly reported various issues above (infinite loop, etc.?).
            But then I also see people providing workarounds.

            In other words, I believe closing and having people report more specific issues would provide clarity and make this more actionable.

            I think I'll close this JIRA in the next days if people don't disagree. *Again*, this is not to say things are great and work perfectly already. The goal is actually to target more a win-win: better clarity, so the current EC2 plugin maintainers (I'm not one) can more easily understand what needs to be fixed and help users here with issues.

            Thanks!

            oleg_nenashev Oleg Nenashev added a comment -

            I also think it could be closed. Some documentation may be helpful, but I do not see anything outstanding left here.

            Please correct me if I am wrong

            francisu Francis Upton added a comment -

            We could wait another few months to close it after it's 10th anniversary.

            oleg_nenashev Oleg Nenashev added a comment -

            Sounds like a planĀ 

            batmat Baptiste Mathus added a comment -

            I'm going to assume Francis was being sarcastic (which I like ), so closing to avoid keeping this misleading for another 10 months or so .

            Please file specific issues if you find something not working. Please read my last comment above: this is NOT being closed because there's no issue at all, but because we want specific issues with reproduction steps to be actually able to understand and fix remaining issues.

            Thanks!


              People

              • Assignee:
                francisu Francis Upton
                Reporter:
                lifeless lifeless
              • Votes:
                27 Vote for this issue
                Watchers:
                35 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: