Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-51691

JEP-200 Compatibility failing to serialize packages needed for successfully passing java pipeline triggered by push on Gitlab

    Details

    • Similar Issues:

      Description

      Im now trying to integrate Gitlab with Jenkin's CI. I did an example pipeline, configured it with my GitLab's PR. If I manually build the pipeline its result is a success but when it's triggered by a push to my Gitlab's PR (this is how i really want it to be).
      .- WebHook working fine.
      .- Gitlab Plugin working fine.

      I'd like to know any suggestion to do, any workaround, I would like to know if the XStream is getting whitelisted anytime soon since i need de CI/CD working fine asap.

      The source code its in JAVA, using maven (Don't remember the version).

        Attachments

        1. Issue1.png
          Issue1.png
          372 kB
        2. Issue1-2.png
          Issue1-2.png
          268 kB

          Issue Links

            Activity

            Hide
            owenmehegan Owen Mehegan added a comment -
            Show
            owenmehegan Owen Mehegan added a comment - Ricardo Amendolia can you explain which plugin you are using for GitLab? Is it https://plugins.jenkins.io/gitlab-merge-request-jenkins or https://plugins.jenkins.io/gitlab-plugin ?
            Show
            exidon Ricardo Amendolia added a comment - Owen Mehegan https://wiki.jenkins.io/display/JENKINS/GitLab+Plugin
            Hide
            owenmehegan Owen Mehegan added a comment -

            Ricardo Amendolia which version of the plugin? We have not used the library that is referred to in your stack trace for a long time.

            Show
            owenmehegan Owen Mehegan added a comment - Ricardo Amendolia which version of the plugin? We have not used the library that is referred to in your stack trace for a long time.
            Hide
            exidon Ricardo Amendolia added a comment -

            Owen Mehegan v1.1.32 a mate had a problem with v1.5 version and downgraded it and it works. I can update it to 1.5 if needed

            Show
            exidon Ricardo Amendolia added a comment - Owen Mehegan v1.1.32 a mate had a problem with v1.5 version and downgraded it and it works. I can update it to 1.5 if needed
            Hide
            owenmehegan Owen Mehegan added a comment - - edited

            Ricardo Amendolia yes it's needed, that version is ancient and unsupported anyway, and now we see that is has this blocking bug. If you have problems with using the latest version, please raise them on the GitHub issues page for the plugin at https://github.com/jenkinsci/gitlab-plugin/issues Your mate is welcome to do that as well

            Also, if you were using this version of the plugin successfully before upgrading Jenkins, you may need to upgrade in two steps to deal with an old config migration bug. You would need to install 1.2.0, and then install the latest. See https://github.com/jenkinsci/gitlab-plugin/issues/473 If you have not been able to use it yet, then this would not impact you and you can just install the latest immediately (or perhaps uninstall, restart, then install).

            I'm going to close this as Not A Defect.

            Show
            owenmehegan Owen Mehegan added a comment - - edited Ricardo Amendolia yes it's needed, that version is ancient and unsupported anyway, and now we see that is has this blocking bug. If you have problems with using the latest version, please raise them on the GitHub issues page for the plugin at https://github.com/jenkinsci/gitlab-plugin/issues Your mate is welcome to do that as well Also, if you were using this version of the plugin successfully before upgrading Jenkins, you may need to upgrade in two steps to deal with an old config migration bug. You would need to install 1.2.0, and then install the latest. See https://github.com/jenkinsci/gitlab-plugin/issues/473 If you have not been able to use it yet, then this would not impact you and you can just install the latest immediately (or perhaps uninstall, restart, then install). I'm going to close this as Not A Defect.

              People

              • Assignee:
                owenmehegan Owen Mehegan
                Reporter:
                exidon Ricardo Amendolia
              • Votes:
                1 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: