Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-51823

Investigate Groovy update from 2.4.11 to 3.0+

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      Groovy 3.0 is required to run ion Java 10.
      Jenkins currently bundles 2.4.11 which is not enough.

      We need to explore whether Groovy-based logic runs well with Java 10, including:

      • Groovy-based UI forms
      • System Groovy Console
      • Plugins using Groovy

        Attachments

          Issue Links

            Activity

            There are no comments yet on this issue.

              People

              • Assignee:
                Unassigned
                Reporter:
                oleg_nenashev Oleg Nenashev
              • Votes:
                1 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated: