Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-52016

Build parameters & env variables not working to Publish Over SSH

    Details

    • Type: Bug
    • Status: Fixed but Unreleased (View Workflow)
    • Priority: Blocker
    • Resolution: Cannot Reproduce
    • Labels:
      None
    • Environment:
      Redhat 7.4 PPC Big Endian
    • Similar Issues:

      Description

      The build parameters and environment variables not working in Publish over ssh. Previously it worked. Now in this version 1.19.1 , it is not working. The parameter values are null so that no files are copied over.

        Attachments

        1. $1AAC62AC63F72136.jpg
          $1AAC62AC63F72136.jpg
          23 kB
        2. $2E738BC7C06B1B7E.jpg
          $2E738BC7C06B1B7E.jpg
          33 kB
        3. $7475F403A56A076E.jpg
          $7475F403A56A076E.jpg
          39 kB
        4. $77B3423DA6BCF691.jpg
          $77B3423DA6BCF691.jpg
          35 kB

          Activity

          ayappan Ayappan Perumal added a comment -

          Jenkins is actually running on a PPC (PowerPC) 64 bit Big Endian RHEL 7.4 machine. 

          slide_o_mix Alex Earl added a comment -

          Environment variables defined in an execute shell step will not propagate past that step. You would need to use something like EnvInject to get them back to be usable in another build step or post-build step. I don't have any access to a PPC machine, but I don't think running on that type of HW is an issue.

          ayappan Ayappan Perumal added a comment -

          Okay we can leave those variables defined in an execute shell step. But the PKG variable defined under "This project is parameterized" should be passed. But that is not happening here. 

          slide_o_mix Alex Earl added a comment -

          I am not able to reproduce this issue. It works for me locally just fine.

          ayappan Ayappan Perumal added a comment -

          Okay. I will test this in one more machine Ubuntu PPC64 Little Endian and update the status.


            People

            • Assignee:
              slide_o_mix Alex Earl
              Reporter:
              ayappan Ayappan Perumal
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: