Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-52838

Azure VM Agents 0.7.2.1 prevents custom images from provisioning

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: azure-vm-agents-plugin
    • Labels:
      None
    • Environment:
      Azure VM Agents 0.7.2.1, on a Jenkins 2.121.2 LTS system.
    • Similar Issues:
    • Released As:
      0.7.3

      Description

      After upgrading from version 0.7.2 to 0.7.2.1, my Jenkins system can no longer provision custom Azure images; my system log fills with exceptions like 

      java.lang.NoSuchFieldError: ADJUST_DATES_TO_CONTEXT_TIME_ZONE
      

      Full stack trace as follows:

      INFO: AzureVMCloudVerificationTask: getVirtualMachineCount: start
      Aug 01, 2018 6:47:22 AM hudson.triggers.SafeTimerTask run
      SEVERE: Timer task hudson.slaves.NodeProvisioner$NodeProvisionerInvoker@3f40eaa5 failed
      java.lang.NoSuchFieldError: ADJUST_DATES_TO_CONTEXT_TIME_ZONE
      	at com.fasterxml.jackson.datatype.joda.cfg.JacksonJodaDateFormat.with(JacksonJodaDateFormat.java:124)
      	at com.fasterxml.jackson.datatype.joda.deser.JodaDateDeserializerBase.createContextual(JodaDateDeserializerBase.java:56)
      	at com.fasterxml.jackson.databind.DeserializationContext.handleSecondaryContextualization(DeserializationContext.java:685)
      	at com.fasterxml.jackson.databind.DeserializationContext.findContextualValueDeserializer(DeserializationContext.java:446)
      	at com.fasterxml.jackson.databind.deser.std.StdDeserializer.findDeserializer(StdDeserializer.java:946)
      	at com.fasterxml.jackson.databind.deser.BeanDeserializerBase.resolve(BeanDeserializerBase.java:446)
      	at com.fasterxml.jackson.databind.deser.DeserializerCache._createAndCache2(DeserializerCache.java:296)
      	at com.fasterxml.jackson.databind.deser.DeserializerCache._createAndCacheValueDeserializer(DeserializerCache.java:244)
      	at com.fasterxml.jackson.databind.deser.DeserializerCache.findValueDeserializer(DeserializerCache.java:142)
      	at com.fasterxml.jackson.databind.DeserializationContext.findContextualValueDeserializer(DeserializationContext.java:444)
      	at com.fasterxml.jackson.databind.deser.std.CollectionDeserializer.createContextual(CollectionDeserializer.java:196)
      	at com.fasterxml.jackson.databind.deser.std.CollectionDeserializer.createContextual(CollectionDeserializer.java:26)
      	at com.fasterxml.jackson.databind.DeserializationContext.handleSecondaryContextualization(DeserializationContext.java:685)
      	at com.fasterxml.jackson.databind.DeserializationContext.findContextualValueDeserializer(DeserializationContext.java:446)
      	at com.fasterxml.jackson.databind.deser.std.StdDeserializer.findDeserializer(StdDeserializer.java:946)
      	at com.fasterxml.jackson.databind.deser.BeanDeserializerBase.resolve(BeanDeserializerBase.java:446)
      	at com.fasterxml.jackson.databind.deser.DeserializerCache._createAndCache2(DeserializerCache.java:296)
      	at com.fasterxml.jackson.databind.deser.DeserializerCache._createAndCacheValueDeserializer(DeserializerCache.java:244)
      	at com.fasterxml.jackson.databind.deser.DeserializerCache.findValueDeserializer(DeserializerCache.java:142)
      	at com.fasterxml.jackson.databind.DeserializationContext.findContextualValueDeserializer(DeserializationContext.java:444)
      	at com.fasterxml.jackson.databind.deser.std.StdDeserializer.findDeserializer(StdDeserializer.java:946)
      	at com.fasterxml.jackson.databind.deser.BeanDeserializerBase.resolve(BeanDeserializerBase.java:446)
      	at com.microsoft.rest.serializer.FlatteningDeserializer.resolve(FlatteningDeserializer.java:114)
      	at com.fasterxml.jackson.databind.deser.DeserializerCache._createAndCache2(DeserializerCache.java:296)
      	at com.fasterxml.jackson.databind.deser.DeserializerCache._createAndCacheValueDeserializer(DeserializerCache.java:244)
      	at com.fasterxml.jackson.databind.deser.DeserializerCache.findValueDeserializer(DeserializerCache.java:142)
      	at com.fasterxml.jackson.databind.DeserializationContext.findContextualValueDeserializer(DeserializationContext.java:444)
      	at com.fasterxml.jackson.databind.deser.std.CollectionDeserializer.createContextual(CollectionDeserializer.java:196)
      	at com.fasterxml.jackson.databind.deser.std.CollectionDeserializer.createContextual(CollectionDeserializer.java:26)
      	at com.fasterxml.jackson.databind.DeserializationContext.handleSecondaryContextualization(DeserializationContext.java:685)
      	at com.fasterxml.jackson.databind.DeserializationContext.findContextualValueDeserializer(DeserializationContext.java:446)
      	at com.fasterxml.jackson.databind.deser.std.StdDeserializer.findDeserializer(StdDeserializer.java:946)
      	at com.fasterxml.jackson.databind.deser.BeanDeserializerBase.resolve(BeanDeserializerBase.java:446)
      	at com.microsoft.rest.serializer.FlatteningDeserializer.resolve(FlatteningDeserializer.java:114)
      	at com.fasterxml.jackson.databind.deser.DeserializerCache._createAndCache2(DeserializerCache.java:296)
      	at com.fasterxml.jackson.databind.deser.DeserializerCache._createAndCacheValueDeserializer(DeserializerCache.java:244)
      	at com.fasterxml.jackson.databind.deser.DeserializerCache.findValueDeserializer(DeserializerCache.java:142)
      	at com.fasterxml.jackson.databind.DeserializationContext.findContextualValueDeserializer(DeserializationContext.java:444)
      	at com.fasterxml.jackson.databind.deser.std.CollectionDeserializer.createContextual(CollectionDeserializer.java:196)
      	at com.fasterxml.jackson.databind.deser.std.CollectionDeserializer.createContextual(CollectionDeserializer.java:26)
      	at com.fasterxml.jackson.databind.DeserializationContext.handleSecondaryContextualization(DeserializationContext.java:685)
      	at com.fasterxml.jackson.databind.DeserializationContext.findContextualValueDeserializer(DeserializationContext.java:446)
      	at com.fasterxml.jackson.databind.deser.std.StdDeserializer.findDeserializer(StdDeserializer.java:946)
      	at com.fasterxml.jackson.databind.deser.BeanDeserializerBase.resolve(BeanDeserializerBase.java:446)
      	at com.fasterxml.jackson.databind.deser.DeserializerCache._createAndCache2(DeserializerCache.java:296)
      	at com.fasterxml.jackson.databind.deser.DeserializerCache._createAndCacheValueDeserializer(DeserializerCache.java:244)
      	at com.fasterxml.jackson.databind.deser.DeserializerCache.findValueDeserializer(DeserializerCache.java:142)
      	at com.fasterxml.jackson.databind.DeserializationContext.findRootValueDeserializer(DeserializationContext.java:477)
      	at com.fasterxml.jackson.databind.ObjectMapper._findRootDeserializer(ObjectMapper.java:3890)
      	at com.fasterxml.jackson.databind.ObjectMapper._readMapAndClose(ObjectMapper.java:3785)
      	at com.fasterxml.jackson.databind.ObjectMapper.readValue(ObjectMapper.java:2817)
      	at com.microsoft.rest.serializer.JacksonAdapter.deserialize(JacksonAdapter.java:131)
      	at com.microsoft.rest.ServiceResponseBuilder.buildBody(ServiceResponseBuilder.java:216)
      	at com.microsoft.rest.ServiceResponseBuilder.build(ServiceResponseBuilder.java:110)
      	at com.microsoft.azure.AzureResponseBuilder.build(AzureResponseBuilder.java:56)
      	at com.microsoft.azure.management.compute.implementation.VirtualMachinesInner.listByResourceGroupDelegate(VirtualMachinesInner.java:1429)
      	at com.microsoft.azure.management.compute.implementation.VirtualMachinesInner.access$800(VirtualMachinesInner.java:48)
      	at com.microsoft.azure.management.compute.implementation.VirtualMachinesInner$47.call(VirtualMachinesInner.java:1416)
      	at com.microsoft.azure.management.compute.implementation.VirtualMachinesInner$47.call(VirtualMachinesInner.java:1412)
      	at rx.internal.operators.OnSubscribeMap$MapSubscriber.onNext(OnSubscribeMap.java:69)
      	at retrofit2.adapter.rxjava.RxJavaCallAdapterFactory$RequestArbiter.request(RxJavaCallAdapterFactory.java:173)
      	at rx.Subscriber.setProducer(Subscriber.java:211)
      	at rx.internal.operators.OnSubscribeMap$MapSubscriber.setProducer(OnSubscribeMap.java:102)
      	at retrofit2.adapter.rxjava.RxJavaCallAdapterFactory$CallOnSubscribe.call(RxJavaCallAdapterFactory.java:152)
      	at retrofit2.adapter.rxjava.RxJavaCallAdapterFactory$CallOnSubscribe.call(RxJavaCallAdapterFactory.java:138)
      	at rx.Observable.unsafeSubscribe(Observable.java:10142)
      	at rx.internal.operators.OnSubscribeMap.call(OnSubscribeMap.java:48)
      	at rx.internal.operators.OnSubscribeMap.call(OnSubscribeMap.java:33)
      	at rx.internal.operators.OnSubscribeLift.call(OnSubscribeLift.java:48)
      	at rx.internal.operators.OnSubscribeLift.call(OnSubscribeLift.java:30)
      	at rx.internal.operators.OnSubscribeLift.call(OnSubscribeLift.java:48)
      	at rx.internal.operators.OnSubscribeLift.call(OnSubscribeLift.java:30)
      	at rx.Observable.subscribe(Observable.java:10238)
      	at rx.Observable.subscribe(Observable.java:10205)
      	at rx.observables.BlockingObservable.blockForSingle(BlockingObservable.java:444)
      	at rx.observables.BlockingObservable.single(BlockingObservable.java:341)
      	at com.microsoft.azure.management.compute.implementation.VirtualMachinesInner.listByResourceGroup(VirtualMachinesInner.java:1329)
      	at com.microsoft.azure.management.resources.fluentcore.arm.collection.implementation.TopLevelModifiableResourcesImpl.listByResourceGroup(TopLevelModifiableResourcesImpl.java:123)
      	at com.microsoft.azure.vmagent.AzureVMManagementServiceDelegate.getVirtualMachineCount(AzureVMManagementServiceDelegate.java:1462)
      	at com.microsoft.azure.vmagent.AzureVMCloudVerificationTask.getVirtualMachineCount(AzureVMCloudVerificationTask.java:191)
      	at com.microsoft.azure.vmagent.AzureVMCloudVerificationTask.verifyCloud(AzureVMCloudVerificationTask.java:143)
      	at com.microsoft.azure.vmagent.AzureVMCloudVerificationTask.verify(AzureVMCloudVerificationTask.java:46)
      	at com.microsoft.azure.vmagent.AzureVMCloud.provision(AzureVMCloud.java:648)
      	at hudson.slaves.NodeProvisioner$StandardStrategyImpl.apply(NodeProvisioner.java:715)
      	at hudson.slaves.NodeProvisioner.update(NodeProvisioner.java:320)
      	at hudson.slaves.NodeProvisioner.access$000(NodeProvisioner.java:61)
      	at hudson.slaves.NodeProvisioner$NodeProvisionerInvoker.doRun(NodeProvisioner.java:809)
      	at hudson.triggers.SafeTimerTask.run(SafeTimerTask.java:72)
      	at jenkins.security.ImpersonatingScheduledExecutorService$1.run(ImpersonatingScheduledExecutorService.java:58)
      	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
      	at java.util.concurrent.FutureTask.runAndReset(FutureTask.java:308)
      	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$301(ScheduledThreadPoolExecutor.java:180)
      	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:294)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
      	at java.lang.Thread.run(Thread.java:748)
      

      Downgrading to 0.7.2 fixes the problem entirely.

        Attachments

          Issue Links

            Activity

            jieshe Jie Shen added a comment -

            Hi Nick Jones,

            Could you please provide more image configuration information to help me investigate the problem, thanks.

            medianick Nick Jones added a comment -

            All the images (I tested with 3 different ones) are based on Windows Server 2016 Datacenter, to which I’ve added OpenSSH and various other build tools we require. I can provide any other specific versions, etc., if useful.

            raphaelyu Raphael Yu added a comment -

            It's caused by version conflicts of jackson. I'll fix it

            azure_devops Azure DevOps added a comment -

            I have made a PR on Github. I will add you as a reviewer Raphael Yu , thanks.

            medianick Nick Jones added a comment -

            I have confirmed that 0.7.3 fixes the problem. Thank you!

            matthias_h Matthias Hinterschwepfinger added a comment -

            Yes, also working for me again. 0.7.3 looks great. Thank you!


              People

              • Assignee:
                jieshe Jie Shen
                Reporter:
                medianick Nick Jones
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: