Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-52849

this window is "Interactive Services Detection" is pop up when tomcat is up

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Not A Defect
    • Labels:
      None
    • Environment:
      jenkins is on windows 7,
      ssh server(FreeSSHd as a service) and tomcat is on windows server 2008 x64
    • Similar Issues:

      Description

      I write in the section "Exec command" of the Publish Over SSH Plugin:

      cmd /c call C:\sftp\myscript.bat $BUILD_NUMBER

      The content of the file myscript.bat is as follow:

      Echo  ---------begin--------

      Echo shutdown tomcat(use port 8080)
      @echo off
      setlocal enabledelayedexpansion
      for /f "delims= tokens=1" %%i in ('netstat -aon ^| findstr "8080"') do (
      set a=%%i
      goto js
      )
      :js
      taskkill /f /pid "Unable to render embedded object: File (~71,5) not found."
      Echo startup tomcat
      @echo off
      C:
      cd C:\software\apache-tomcat-6.0.39\bin
      call startup.bat

      Echo  ---------end--------

      issue reproduced as follow steps:

      1.jenkins execute myscript.bat file successfully.

      2.log on the windows server 2008 machine which the ssh server & tomcat is on.

      3.i find a window is prompt,this window is "Interactive Services Detection"

      4.i don't know why this window is pop up,can you give me suggestion?i also attach 3 images to explain this question.

        Attachments

        1. 1-1.png
          1-1.png
          119 kB
        2. 1-2.png
          1-2.png
          240 kB
        3. 1-3.jpg
          1-3.jpg
          12 kB
        4. ok.png
          ok.png
          116 kB

          Activity

          slide_o_mix Alex Earl added a comment -

          This is not a bug, please read the following blog for information about this popup.

           

          https://blogs.msdn.microsoft.com/patricka/2010/04/27/what-is-interactive-services-detection-and-why-is-it-blinking-at-me/

          09121984 jn cheng added a comment - - edited

          Thanks a lot.

          After read article you shared,i have solved this problem.

          Everything work correct,see picture "ok.png"

          Oh,this problem can be close now.

          Br.


            People

            • Assignee:
              slide_o_mix Alex Earl
              Reporter:
              09121984 jn cheng
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: