Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-52875

Joda time class not found exception in git plugin changeset calculation

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Labels:
      None
    • Environment:
      - Google Version 67.0.3396.99 (Official Build) (32-bit)
      - Git bitbacket server
      - Jenkins ver. 2.89.4
      - Windows server 2012
      - Weblogic
      - Java 8
    • Similar Issues:

      Description

      This problem is occurring occasionally when I use the Git. Before i use svn no have the problem.

      I tried the find many solution but not resolve.

      Thank you so much.

        Attachments

          Activity

          markewaite Mark Waite added a comment -

          Sorry that you've encountered a problem. Please help maintainers like me to want to help you.

          A brief description that you're having a general problem with a screenshot of a stack trace requires that I work much harder to guess the problem, then guess the cause of the problem, then guess what steps you're taking which are showing the problem, then guess what alternatives you might use to work around the problem. That's a lot of work and a lot of guessing for the very few people that work on the git plugin. When I'm given a choice between working on something that requires a lot of guessing and something that has more specific and detailed instructions, I will almost always choose to work on the more specific question.

          Please use the instructions in "How to report an issue" to provide at least the following information:

          • Numbered, detailed description of the steps which another person (like me) can take to see the problem you are seeing on a fresh installation. If you cannot duplicate the problem in a fresh installation, describe the configurations where you attempted to duplicate the problem
          • Jenkins support bundle that shows the installed plugin versions in your installation and other useful information about your installation
          • Agent configuration where the failure is being reported (is the job executing on an agent or on the master)
          • Job definition of the job that is showing the problem (the config.xml file for the job)
          • Paste the text of the stack trace into the bug description so that it can be found by search engines and read by other tools
          • Review JENKINS-34357 which reports a similar stack trace to see if you have a "git.jpi" and a "git.hpi" file in your plugins directory
          • Review JENKINS-43103 to see if you have an older version of the Jacoco plugin installed which might need to be updated
          • Review the SonarQube analysis stackoverflow article in case you have an older version of the SonarQube plugin which might be causing the problem
          markewaite Mark Waite added a comment -

          Since the submitter of the bug report has not replied to the request for additional information and I cannot duplicate the problem, I'm closing the bug


            People

            • Assignee:
              Unassigned
              Reporter:
              bamossza Panusitt Khuenkham
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: