Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-5296

Commands not printed during remote builds

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Similar Issues:

      Description

      If there is problem with SCM polling hanging (as in JENKINS-4461) and you try to manually start a job, Hudson will duly schedule it on an executor and then seem to run it. When you look at the console, it says e.g.

      --%<--
      Console Output
      --------------
      Started by user jglick
      Building remotely on someslave
      --%<--

      and then nothing else happens - indefinitely. This is not friendly.

      If the build has to wait to acquire a workspace lock, it should say so... and give you information about how to kill any outstanding polling process (JENKINS-4479).

        Attachments

          Activity

          jglick Jesse Glick added a comment -

          I think the problem is something else. When I run a build using Mercurial on master, I see:

          Started by an SCM change
          Building on master
          [workspace] $ /usr/bin/hg update --clean .
          0 files updated, 0 files merged, 0 files removed, 0 files unresolved
          [workspace] $ /usr/bin/hg --config extensions.purge= clean --all
          [workspace] $ /usr/bin/hg incoming --quiet --bundle hg.bundle --template "<changeset node='

          {node}' author='{author|xmlescape}' rev='{rev}' date='{date}'><msg>{desc|xmlescape}</msg><added>{file_adds|stringify|xmlescape}</added><deleted>{file_dels|stringify|xmlescape}</deleted><files>{files|stringify|xmlescape}</files><parents>{parents}</parents></changeset>\n" --rev default
          [workspace] $ /usr/bin/hg pull hg.bundle
          pulling from hg.bundle
          searching for changes
          adding changesets
          adding manifests
          adding file changes
          added 1 changesets with 1 changes to 1 files
          (run 'hg update' to get a working copy)
          [workspace] $ /usr/bin/hg update --clean --rev default
          1 files updated, 0 files merged, 0 files removed, 0 files unresolved
          [workspace] $ /usr/bin/hg log --rev . --template {node}

          Starting xvnc
          [workspace] $ /opt/csw/bin/vncserver :28 -geometry 800x600
          New 'X' desktop is bertram:28
          [....and then the rest of the build....]

          When I run a comparable build on a slave, I see only

          Started by user jglick
          Building remotely on beefy
          0 files updated, 0 files merged, 0 files removed, 0 files unresolved
          pulling from hg.bundle
          searching for changes
          adding changesets
          adding manifests
          adding file changes
          added 1 changesets with 6 changes to 6 files
          (run 'hg update' to get a working copy)
          6 files updated, 0 files merged, 0 files removed, 0 files unresolved
          Starting xvnc
          New 'X' desktop is beefy:30
          [....and then the rest of the build....]

          No wonder it looks like nothing is happening - various time-consuming commands are being run but no indication of this is printed.

          LocalLauncher.launch immediately calls maskedPrintCommandLine. But RemoteLauncher.launch does not appear to do anything comparable. RemoteLaunchCallable.call does call LocalLauncher.launch, but it constructs it with TaskListener.NULL!

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in hudson
          User: : jglick
          Path:
          trunk/hudson/main/core/src/main/java/hudson/Launcher.java
          http://fisheye4.cenqua.com/changelog/hudson/?cs=25870
          Log:
          [FIXED JENKINS-5296] Remote launcher failed to print any of the commands it was running to the listener the way the local launcher does.

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in hudson
          User: : jglick
          Path:
          trunk/www/changelog.html
          http://fisheye4.cenqua.com/changelog/hudson/?cs=25874
          Log:
          JENKINS-5296 Noting.


            People

            • Assignee:
              Unassigned
              Reporter:
              jglick Jesse Glick
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: