Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-53073

HPLauncher Throws Error (HP PlugIn)

    Details

    • Similar Issues:

      Description

      We’re using the HP Test Automation Tools plug-in to run automated UFT tests from Jenkins. 

      Test jobs are initiated from Jenkins Master and execute on Jenkins Agent machines (Windows 7 Desktop).  See the snippet below, from the Jenkins Console log, that shows the HPToolsLauncher command.

       

      10:38:51 [OFFPIPELINE_mvp_ioi_regression_test_01_stage2] $ C:\Jenkins\workspace\OFFPIPELINE_mvp_ioi_regression_test_01_stage2\HpToolsLauncher.exe -paramfile props16082018103851125.txt

       

      When the logged-in user to the Agent machine is an Admin User the test job runs successfully -> UFT test is launched on the Agent machine, runs to completion and reports results back to Jenkins Master.

       

      Whereas, when the logged-in user to the Agent machine is a non-Admin User the test job throws an error:

       

      10:38:51 16/08/2018 10:38:51 Running: C:\Jenkins\workspace\OFFPIPELINE_mvp_ioi_regression_test_01_stage2\IOI_PDF_Compare\IOI_PDF_Compare

      10:38:51 Test result: Error

      10:38:51 16/08/2018 10:38:51 Test complete:

       

      The Results file indicates the following:

       

      name="C:\Jenkins\workspace\OFFPIPELINE_mvp_ioi_regression_test_01_stage2\IOI_PDF_Compare\IOI_PDF_Compare"><error message="Unable to change DCOM settings. To chage it manually: run dcomcnfg.exe -> My Computer -> DCOM Config -> QuickTest Professional Automation -> Identity -> and select The Interactive Userdetailed error is : Requested registry access is not allowed."/>

       

       

      Q:  Are Admin Rights required (for the account under which the UFT test is being executed on the Agent machine) in order to utilize the plug-in?

       

      Q:  If not, what must be done to resolve the error?

        Attachments

          Activity

          Hide
          gront Daniel Gront added a comment -

           Hey Jim Cook, what version of UFT are you using?

          Show
          gront Daniel Gront added a comment -  Hey Jim Cook , what version of UFT are you using?
          Hide
          jcookjenkins Jim Cook added a comment -

          Hi Daniel and Anda:  We are running UFT 12.54.

          Show
          jcookjenkins Jim Cook added a comment - Hi Daniel and Anda:  We are running UFT 12.54.
          Hide
          manjuec12 MANJU added a comment -

          Hi Team,

          any updates on this issue?

          i have the same problem.

          Regards,

          Manju

          Show
          manjuec12 MANJU added a comment - Hi Team, any updates on this issue? i have the same problem. Regards, Manju
          Hide
          aslaakso Anda Sorina Laakso added a comment -

          Did you try to run the command indicated in the result file?

          Show
          aslaakso Anda Sorina Laakso added a comment - Did you try to run the command indicated in the result file?
          Hide
          manjuec12 MANJU added a comment -

          Hi,

          command given in jenkins file is :

          c:\jenkins\workspace\TA\HpToolsLauncher.exe -paramfile props13122019112708250.txt

           i executed this command directly in slaves's command prompt, it throws an error- path for paramfile doesn't exist hence I executed the following command with the complete path to paramfile, it's working 

          c:\jenkins\workspace\TA\HpToolsLauncher.exe -paramfile c:\jenkins\workspace\TA\props13122019112708250.txt

          but if i execute the job from jenkins it won't work, please refer the screenshot below:

           

          Show
          manjuec12 MANJU added a comment - Hi, command given in jenkins file is : c:\jenkins\workspace\TA\HpToolsLauncher.exe -paramfile props13122019112708250.txt  i executed this command directly in slaves's command prompt, it throws an error- path for paramfile doesn't exist hence I executed the following command with the complete path to paramfile, it's working  c:\jenkins\workspace\TA\HpToolsLauncher.exe -paramfile c:\jenkins\workspace\TA\props13122019112708250.txt but if i execute the job from jenkins it won't work, please refer the screenshot below:  
          Hide
          aslaakso Anda Sorina Laakso added a comment -

          As I see from the pictured attached, you are using "Execute Windows batch command" type of task, not the tasks included in our plugin.
          And I was referring to this command:
          "Unable to change DCOM settings. To chage it manually: run dcomcnfg.exe -> My Computer -> DCOM Config -> QuickTest Professional Automation -> Identity -> and select The Interactive Userdetailed error is : Requested registry access is not allowed."

          Show
          aslaakso Anda Sorina Laakso added a comment - As I see from the pictured attached, you are using "Execute Windows batch command" type of task, not the tasks included in our plugin. And I was referring to this command: "Unable to change DCOM settings. To chage it manually: run dcomcnfg.exe -> My Computer -> DCOM Config -> QuickTest Professional Automation -> Identity -> and select The Interactive Userdetailed error is : Requested registry access is not allowed."
          Hide
          manjuec12 MANJU added a comment -

          Hi, 

          sorry that was the wrong screenshot, as i was also trying to use execute from windows batch command.

          its the same error when i execute using the plugin given option :

          I checked the dcom settings, it is 'Interactve' user only.

           

          Show
          manjuec12 MANJU added a comment - Hi,  sorry that was the wrong screenshot, as i was also trying to use execute from windows batch command. its the same error when i execute using the plugin given option : I checked the dcom settings, it is 'Interactve' user only.  
          Hide
          manjuec12 MANJU added a comment - - edited

          Hi, 

          I just opened DCOM config in admin mode and added my user in the configuration permissions of DCOM security

          now, its working fine.

           

          Regards,

          Manju

          Show
          manjuec12 MANJU added a comment - - edited Hi,  I just opened DCOM config in admin mode and added my user in the configuration permissions of DCOM security now, its working fine.   Regards, Manju

            People

            • Assignee:
              aslaakso Anda Sorina Laakso
              Reporter:
              jcookjenkins Jim Cook
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: