Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-53210

Scan Organisation no longer triggering project scans

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: branch-api-plugin
    • Labels:
      None
    • Environment:
      OS: Ubuntu 16.04 x86-64
      Jenkins: 2.121.3
      branch-api: 2.0.20
      workflow-multibranch: 2.20
      github-branch-source: 2.3.6
    • Similar Issues:

      Description

      We use Jenkins behind a firewall where we can't use Github event hooks, so we have a Github organisation project that periodically polls.

      After a Jenkins upgrade, we found updates aren't triggering builds. The problem appears to be that after the organisation scan, it is no longer scanning the individual repositories in the organisation. We can see that the timestamps in the scan log for the organisation are recent but those for each individual repository are old. Manually triggering a repository scan has the desired effect.

      I've set up a toy Jenkins installation and reproduced the problem with all-latest plugins. It seems to be a regression between branch-api 2.0.16 and 2.0.17: if I downgrade workflow-multibranch to 2.16 (to fix dependency problems) and switch branch-api between 2.0.16 and 2.0.17 then it works as desired with 2.0.16 but fails with 2.0.17.

       

        Attachments

          Issue Links

            Activity

            stephenconnolly Stephen Connolly added a comment -

            Removing myself as assignee. My current work assignments do not provide sufficient bandwidth to review these issues and in the majority of cases I am only assigned by virtue of being the default assignee. For the credentials-api and scm-api related plugins I have permission to allocate time reviewing changes to these APIs themselves to ensure these APIs remain cohesive, but that can be handled through PR reviews rather than assigning issues in JIRA

            bmerry Bruce Merry added a comment -

            This is more-or-less addressed by https://issues.jenkins-ci.org/browse/JENKINS-56917: one can now configure the project to set the polling interval for children.


              People

              • Assignee:
                Unassigned
                Reporter:
                bmerry Bruce Merry
              • Votes:
                1 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: