Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-5329

Gcc parser parses some filenames incorrectly

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Won't Fix
    • Component/s: warnings-plugin
    • Labels:
      None
    • Environment:
      Master is a Windows machine, slave a Linux. Warnings plugin v3.1
    • Similar Issues:

      Description

      There seems to be some problem parsing the file locations:
      workspace=In file included from ../../CLIB/ApplicationSettings.cpp

      When trying to see the contents of a file, I get:

      Content of file ApplicationSettings.cpp
      null
      01 hudson.util.IOException2: remote file operation failed: In file included from ../../CLIB/ApplicationSettings.cpp at hudson.remoting.Channel@41f227:Linux Builder
      02 at hudson.FilePath.act(FilePath.java:672)
      03 at hudson.FilePath.act(FilePath.java:660)
      04 at hudson.FilePath.copyTo(FilePath.java:1287)
      05 at hudson.plugins.analysis.core.HealthAwarePublisher.copyFilesWithAnnotationsToBuildFolder(HealthAwarePublisher.java:185)
      06 at hudson.plugins.analysis.core.HealthAwarePublisher.perform(HealthAwarePublisher.java:148)
      07 at hudson.tasks.BuildStepMonitor$2.perform(BuildStepMonitor.java:27)
      08 at hudson.model.AbstractBuild$AbstractRunner.perform(AbstractBuild.java:582)
      09 at hudson.model.AbstractBuild$AbstractRunner.performAllBuildStep(AbstractBuild.java:563)
      10 at hudson.model.AbstractBuild$AbstractRunner.performAllBuildStep(AbstractBuild.java:550)
      11 at hudson.model.Build$RunnerImpl.post2(Build.java:152)
      12 at hudson.model.AbstractBuild$AbstractRunner.post(AbstractBuild.java:534)
      13 at hudson.model.Run.run(Run.java:1216)
      14 at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      15 at hudson.model.ResourceController.execute(ResourceController.java:88)
      16 at hudson.model.Executor.run(Executor.java:122)
      17 Caused by: java.io.FileNotFoundException: In file included from ../../CLIB/ApplicationSettings.cpp (No such file or directory)
      18 at java.io.FileInputStream.open(Native Method)
      19 at java.io.FileInputStream.<init>(FileInputStream.java:106)
      20 at hudson.FilePath$30.invoke(FilePath.java:1291)
      21 at hudson.FilePath$30.invoke(FilePath.java:1287)
      22 at hudson.FilePath$FileCallableWrapper.call(FilePath.java:2062)
      23 at hudson.remoting.UserRequest.perform(UserRequest.java:104)
      24 at hudson.remoting.UserRequest.perform(UserRequest.java:48)
      25 at hudson.remoting.Request$2.run(Request.java:270)
      26 at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:417)
      27 at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:269)
      28 at java.util.concurrent.FutureTask.run(FutureTask.java:123)
      29 at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:651)
      30 at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:676)
      31 at java.lang.Thread.run(Thread.java:595)
      32 Can't copy file from workspace to build folder: workspace=In file included from ../../CLIB/ApplicationSettings.cpp, build folder=d:\ci\jobs\linux beta\builds\2010-01-20_15-29-03\workspace-files\8716a6d6.tmp

      Log message:
      g++-4.1 -DLIBSTDCPP6 -DFLOGGER_USE_XLOGGING -DUSE_FLOGGER -DFLOGGER_ENABLE_ALL -DISD_DEBUG -I/home/ntr/workspace/linux beta/beta/Linux/CLIENT -I/home/ntr/workspace/linux beta/beta/Linux/third_party/libcurl/include -I/home/ntr/workspace/linux beta/beta/Linux/CLIB -I/home/ntr/workspace/linux beta/beta/Linux/FT -I/home/ntr/workspace/linux beta/beta/CLIB -I/home/ntr/workspace/linux beta/beta/Linux/GUIX -I/home/ntr/workspace/linux beta/beta/Linux/third_party/openssl/include -I/usr/include/libxml2 -O0 -fshort-wchar -g3 -pedantic -Wall -c -fmessage-length=0 -W -Wno-long-long -oCLIB/ApplicationSettings.o ../../CLIB/ApplicationSettings.cpp
      In file included from ../../CLIB/ApplicationSettings.cpp:15:
      ../../CLIB/xlogging.h:20:14: warning: anonymous variadic macros were introduced in C99
      In file included from ../../CLIB/ApplicationSettings.cpp:16:
      ../../CLIB/xlogging.h:20:14: warning: anonymous variadic macros were introduced in C99

        Attachments

          Issue Links

            Activity

            drulli Ulli Hafner added a comment -

            How many warnings do you expect in that case? And what should be the message and filename and line number?

            See also the discussion in JENKINS-4753.

            drulli Ulli Hafner added a comment -

            Is there a way to use absolute path names? The plug-in assumes that the files are stored in HUDSON_HOME/relative/path.

            drulli Ulli Hafner added a comment -

            Please reopen if you can provide some answers.


              People

              • Assignee:
                drulli Ulli Hafner
                Reporter:
                pestalella pestalella
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: