Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-53402

Connection to ALM Octane server failed

    Details

    • Similar Issues:

      Description

      Hi,

      In Jenkins System Configuration, under "ALM Octane CI" section, the option "Test Connection" is fine.

      But, inside a job main view, when I hit "HPE ALM Octane Pipelines" link in left menu (below Build Now), I'm getting "Connection to ALM Octane server failed"

      Notes:

      • I can make requests to Octane API (authentication API and listing Octane workspaces) from the server that is hosting Jenkins, using curl and nodejs. But I have to disable SSL certificate validation option since my octane server certificate is not valid.
      • I'm behind a Proxy.

      Thanks for helping

        Attachments

        1. all.log
          5 kB
        2. alm_octane_pipelines_job_link.PNG
          alm_octane_pipelines_job_link.PNG
          45 kB
        3. image-2018-11-05-13-12-27-989.png
          image-2018-11-05-13-12-27-989.png
          44 kB
        4. image-2018-11-05-13-17-24-049.png
          image-2018-11-05-13-17-24-049.png
          52 kB
        5. nga.log
          24 kB
        6. test_connection_ok.PNG
          test_connection_ok.PNG
          37 kB

          Activity

          Hide
          mseldin Michael Seldin added a comment - - edited

          Adnane SAGHIR 

          When you enter the configuration area in jenkins, you have the octane plugin configuration part. (uri : [your jenkins server url]/configure)
          After filling in the octane server details you can click on the "test connection" button - 
          does the check connection works?

           

           

          Show
          mseldin Michael Seldin added a comment - - edited Adnane SAGHIR   When you enter the configuration area in jenkins, you have the octane plugin configuration part. (uri : [your jenkins server url] /configure) After filling in the octane server details you can click on the "test connection" button -  does the check connection works?    
          Hide
          mseldin Michael Seldin added a comment - - edited

          also can you reach the server from the test connection page in plugin management?

           

           

           

          Show
          mseldin Michael Seldin added a comment - - edited also can you reach the server from the test connection page in plugin management?      
          Hide
          3psilon Adnane SAGHIR added a comment -

          The connection test is fine in both "System Config" and in "Proxy Config"

          Show
          3psilon Adnane SAGHIR added a comment - The connection test is fine in both "System Config" and in "Proxy Config"
          Hide
          mseldin Michael Seldin added a comment -

          please follow this video again for proper configuration steps:

          https://www.youtube.com/watch?v=nerPJIuPfV4&feature=youtu.be

           

          if this doesn't help, you can open a support request in the support ticketing system. 

           

          Show
          mseldin Michael Seldin added a comment - please follow this video again for proper configuration steps: https://www.youtube.com/watch?v=nerPJIuPfV4&feature=youtu.be   if this doesn't help, you can open a support request in the support ticketing system.   
          Hide
          3psilon Adnane SAGHIR added a comment -

          Fixed in plugin version 5.6

          Show
          3psilon Adnane SAGHIR added a comment - Fixed in plugin version 5.6

            People

            • Assignee:
              mseldin Michael Seldin
              Reporter:
              3psilon Adnane SAGHIR
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: