Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-53463

NodeJS plugin - NodeJS installation not working correctly

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Not A Defect
    • Component/s: nodejs-plugin
    • Labels:
    • Environment:
      Unix Slave
      java.version:- 1.8.0_144
      os.name:- Linux
      os.version:- 3.13.0-135-generic
      PATH:- /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games
      PWD:- /root
      SHELL:- /bin/bash
    • Similar Issues:

      Description

      NodeJS plugin doesn't install version specified on Slave

      Job Configuration

      Job Console Output

      NodeJS Plugin Config

        Attachments

        1. NodeJSInstall.PNG
          NodeJSInstall.PNG
          117 kB
        2. NodeJSJobConfig.PNG
          NodeJSJobConfig.PNG
          21 kB
        3. NodeJSPlugin.PNG
          NodeJSPlugin.PNG
          30 kB

          Activity

          nfalco Nikolas Falco added a comment - - edited

          This happens because you have already a NodeJS installed in the machine and its bin path is before that one contributed by the plugin in the PATH variable. The only way is to uninstall embedded NodeJS installation, because by design any tool path is always append at the end to the system PATH variable.

          matt_finn Matthew Finn added a comment -

          Perfect thanks Nikolas Falco

          I was thinking it was something along those lines alright


            People

            • Assignee:
              nfalco Nikolas Falco
              Reporter:
              matt_finn Matthew Finn
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: