Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-53816

[Blue Ocean] Completed stages appear to be skipped instead of finished

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      After fix https://issues.jenkins-ci.org/browse/JENKINS-53311 completed stages appear to be skipped instead of finished.

      Pipeline script and screenshot have attached

       

        Attachments

          Issue Links

            Activity

            Hide
            sophistifunk Josh McDonald added a comment -

            Fix in master @ 9d8593973dd6c19dc98440effcf8c7abd158ccef

            Show
            sophistifunk Josh McDonald added a comment - Fix in master @ 9d8593973dd6c19dc98440effcf8c7abd158ccef
            Hide
            borisivan boris ivan added a comment - - edited

            Hi Josh McDonald – I can confirm that some completed stages are still showing as transparent, in Blue Ocean 1.17.

            I think that some parallel stages that had a single stage were previously not showing correctly sometimes, and that seems to have improved.

            But a stage that has parallel stages that each have sequential stages in them are still showing as transparent when complete, though as before, it paints correctly as soon as the pipeline finishes.

            For example:

            --a--b--c

            --d--e--f

            If d completes, it shows as transparent (incorrect). I'm also now seeing that if "e" is active, it sometimes doesn't have the blue animation showing as active. Things may have gotten worse.

            Show
            borisivan boris ivan added a comment - - edited Hi Josh McDonald – I can confirm that some completed stages are still showing as transparent, in Blue Ocean 1.17. I think that some parallel stages that had a single stage were previously not showing correctly sometimes, and that seems to have improved. But a stage that has parallel stages that each have sequential stages in them are still showing as transparent when complete, though as before, it paints correctly as soon as the pipeline finishes. For example: -- a -- b --c -- d -- e --f If d completes, it shows as transparent (incorrect). I'm also now seeing that if "e" is active, it sometimes doesn't have the blue animation showing as active. Things may have gotten worse.
            Hide
            znerd Ernst de Haan added a comment -

            Status is “Fixed But Unreleased” – but it seems this has been released in BlueOcean 1.17.0, see:

            Show
            znerd Ernst de Haan added a comment - Status is “Fixed But Unreleased” – but it seems this has been released in BlueOcean 1.17.0, see: https://github.com/jenkinsci/blueocean-plugin/pull/1961 https://github.com/jenkinsci/blueocean-plugin/releases/tag/blueocean-parent-1.17.0
            Hide
            vivek Vivek Pandey added a comment -

            Fixed and released in Blueocean 1.17.0.

            Show
            vivek Vivek Pandey added a comment - Fixed and released in Blueocean 1.17.0.
            Hide
            vivek Vivek Pandey added a comment -

            Missed comment above that it still doesn't fix reported issue specially with parallel sequential stages.

            Show
            vivek Vivek Pandey added a comment - Missed comment above that it still doesn't fix reported issue specially with parallel sequential stages.

              People

              • Assignee:
                sophistifunk Josh McDonald
                Reporter:
                zakharovdi Denis Zakharov
              • Votes:
                4 Vote for this issue
                Watchers:
                8 Start watching this issue

                Dates

                • Created:
                  Updated: