Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-53828

GitHub Enterprise Servers plugin - ERROR - This URL requires POST

    Details

    • Similar Issues:

      Description

      Plugin configuration shows ERROR for URL validation.

      This URL requires POST

      The URL you're trying to access requires that requests be sent using POST (like a form submission). The button below allows you to retry accessing this URL using POST. URL being accessed:

       

      There is a discussion ongoing on stackoverflow/superuser.

      https://superuser.com/questions/1336804/jenkins-github-enterprise-servers-api-endpoint-error-requires-post

      It does look like this is a bug or mismatch between the latest versions of the github-branch-source plugin (v2.3.6) and the github plugin (v1.29.1). From a quick triage it looks like the affected call is https://github.com/jenkinsci/github-branch-source-plugin/blame/5646416554d58fe224be382baa021df1b601f302/src/main/java/org/jenkinsci/plugins/github_branch_source/Endpoint.java#L154 and the related changeset at https://github.com/jenkinsci/github-branch-source-plugin/commit/22d3383002274bc3f4368534eba2b5c852e78b39. 

        Attachments

          Issue Links

            Activity

            Hide
            vivek Vivek Pandey added a comment -

            Probably duplicate of https://issues.jenkins-ci.org/browse/JENKINS-54051? What version of github-branch-source plugin you are using?

            Show
            vivek Vivek Pandey added a comment - Probably duplicate of https://issues.jenkins-ci.org/browse/JENKINS-54051? What version of github-branch-source plugin you are using?
            Hide
            ba_magna Bosse Arndt added a comment -

            Hi,

            is there a workaround available for this issue?

            At the mentioned URL there was proposed to downgrade the versions of git, github and git-branch plugin. Is it fixing the issue?

            Best regards
            Bosse

             

            Show
            ba_magna Bosse Arndt added a comment - Hi, is there a workaround available for this issue? At the mentioned URL there was proposed to downgrade the versions of git, github and git-branch plugin. Is it fixing the issue? Best regards Bosse  
            Hide
            ba_magna Bosse Arndt added a comment -

            Hi Vivek Pandey,

            I agree with you about the doublication of the issue.

            BR

            Bosse

            Show
            ba_magna Bosse Arndt added a comment - Hi Vivek Pandey , I agree with you about the doublication of the issue. BR Bosse

              People

              • Assignee:
                Unassigned
                Reporter:
                gabel Martin F
              • Votes:
                3 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: