Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-53842

Upgrade Maven version used for Blue Ocean CI

    Details

    • Similar Issues:
    • Epic Link:

      Description

      I just filed a PR to be able to publish incremental releases in Blue Ocean, but got an error showing that https://ci.blueocean.io/ actually runs Maven 3.3.3

      [INFO] --- maven-enforcer-plugin:3.0.0-M1:display-info (display-info) @ jenkins-design-language ---
      [INFO] Maven Version: 3.3.3
      [INFO] JDK Version: 1.8.0_181 normalized as: 1.8.0-181
      [INFO] OS Info: Arch: amd64 Family: unix Name: linux Version: 4.4.0-1048-aws
      [INFO] 
      [INFO] --- maven-enforcer-plugin:3.0.0-M1:enforce (display-info) @ jenkins-design-language ---
      [WARNING] Rule 0: org.apache.maven.plugins.enforcer.RequireMavenVersion failed with message:
      3.5.0+ required to use Incrementals.
      

      I would be nice to upgrade both for making it compatible with Incrementals, and well also in general because upgrading is a good thing nay?

      Thanks!

        Attachments

          Activity

          Show
          olamy Olivier Lamy added a comment - pr https://github.com/jenkinsci/blueocean-plugin/pull/1819  

            People

            • Assignee:
              olamy Olivier Lamy
              Reporter:
              batmat Baptiste Mathus
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: