Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-54666

vsphere plugin job succesful but VMs in vcenter not created

    Details

    • Type: Improvement
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Incomplete
    • Component/s: vsphere-cloud-plugin
    • Labels:
      None
    • Environment:
      Jenkins 2.138.2
      vSphere Plugin 2.18
    • Similar Issues:

      Description

      Started by user
      ***********|http://*******.com:8080/user/*******]
      [EnvInject] - Loading node environment variables.
      Building remotely on
      drake
      in workspace C:\cygwin\home\current\workspace\DeployVM
      [vSphere]
      [vSphere] Performing vSphere build step: "Deploy VM from template"
      [vSphere] Attempting to use server configuration: "E**Vcenter"
      [vSphere] Deploying new vm "AUTNEW" from template "*******_Template"
      Finished: SUCCESS

      Above logs are displayed in console logs of vsphere job, But when i checked the vcenter for the VM existence VM is not created. Still the jenkins says job status success.

      I am blocked because of this and no VM creation is happening.
      But Datastore is available in vsphere.
      Attached logsJenkins.txt from /var/log/jenkins/.

        Attachments

        1. logsJenkins.txt
          5 kB
        2. Config2.png
          Config2.png
          23 kB
        3. Config1.png
          Config1.png
          32 kB

          Issue Links

            Activity

            velan Velan Nagarajan added a comment -

            Sorted out the issue, I was using Datastore_Cluster name in place of individual datastore name,

            Hence i have marked this as an improvements.
            As while using for CICD whenever the datastore gets exhausted manual intervention is required to change to other datastore, If the Datastore Cluster value is also accepted for VM provisioning that would support CICD.

            pjdarton pjdarton added a comment -

            If you want to raise an enhancement request, you'll need to add a lot more information describing exactly what it is you want done ... and then you'll probably end up having to implement it yourself.

            With the description as-is, this is user-error being hidden by JENKINS-38472 - the logs show what the issue is but the build isn't reporting the error.  If there's a specific enhancement that you think would help (aside from JENKINS-38472) feel free to re-open and provide a full description.


              People

              • Assignee:
                Unassigned
                Reporter:
                velan Velan Nagarajan
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: