Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-54713

UI Exception after upgraden plugins

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: trilead-api-plugin
    • Labels:
      None
    • Environment:
      Jenkins ver. 2.151
    • Similar Issues:

      Description

      After updating some plugins jenkins ui is rendered unusable.
      It shows very shorty the expacted page but the switches to a broken page only showing some kind of stacktrace/broken page mixture. The same stacktrace is also in the logfile:

      Caused by: java.lang.NoClassDefFoundError: com/trilead/ssh2/crypto/Base64
              at hudson.plugins.translation.L10nDecorator.encodeRecording(L10nDecorator.java:97)
              at sun.reflect.GeneratedMethodAccessor222.invoke(Unknown Source)
              at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
              at java.lang.reflect.Method.invoke(Method.java:498)
              at org.apache.commons.jexl.util.introspection.UberspectImpl$VelMethodImpl.invoke(UberspectImpl.java:258)
              at org.apache.commons.jexl.parser.ASTMethod.execute(ASTMethod.java:104)
              at org.apache.commons.jexl.parser.ASTReference.execute(ASTReference.java:83)
              at org.apache.commons.jexl.parser.ASTReference.value(ASTReference.java:57)
              at org.apache.commons.jexl.parser.ASTReferenceExpression.value(ASTReferenceExpression.java:51)
              at org.apache.commons.jexl.ExpressionImpl.evaluate(ExpressionImpl.java:80)
              at hudson.ExpressionFactory2$JexlExpression.evaluate(ExpressionFactory2.java:74)
              at org.apache.commons.jelly.parser.EscapingExpression.evaluate(EscapingExpression.java:24)
              at org.apache.commons.jelly.impl.ExpressionScript.run(ExpressionScript.java:66)
              at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
              at org.kohsuke.stapler.jelly.ReallyStaticTagLibrary$1.run(ReallyStaticTagLibrary.java:99)
              at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
              at org.kohsuke.stapler.jelly.CallTagLibScript$1.run(CallTagLibScript.java:99)
              at org.apache.commons.jelly.tags.define.InvokeBodyTag.doTag(InvokeBodyTag.java:91)
              at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:269)
              ... 72 more
      

      The plugins I updated should be the following ones:

      ls -lrt jenkins/plugins
      -rw-r--r-- 1 xxxx xxxx  281390 20. Nov 07:26 branch-api.jpi
      -rw-r--r-- 1 xxxx xxxx   51513 20. Nov 07:26 durable-task.jpi
      -rw-r--r-- 1 xxxx xxxx  215545 20. Nov 07:26 cloudbees-folder.jpi
      -rw-r--r-- 1 xxxx xxxx 2599005 20. Nov 07:26 git-client.jpi
      -rw-r--r-- 1 xxxx xxxx  385003 20. Nov 07:26 trilead-api.jpi
      -rw-r--r-- 1 xxxx xxxx  104090 20. Nov 07:26 ssh-slaves.jpi
      -rw-r--r-- 1 xxxx xxxx   26561 20. Nov 07:26 display-url-api.jpi
      -rw-r--r-- 1 xxxx xxxx  154949 20. Nov 07:26 workflow-api.jpi
      -rw-r--r-- 1 xxxx xxxx   19109 20. Nov 07:26 pipeline-graph-analysis.jpi
      drwxr-xr-x 4 xxxx xxxx    4096 20. Nov 07:27 trilead-api
      drwxr-xr-x 4 xxxx xxxx    4096 20. Nov 07:27 git-client
      drwxr-xr-x 4 xxxx xxxx    4096 20. Nov 07:27 workflow-api
      drwxr-xr-x 5 xxxx xxxx    4096 20. Nov 07:27 cloudbees-folder
      drwxr-xr-x 4 xxxx xxxx    4096 20. Nov 07:27 pipeline-graph-analysis
      drwxr-xr-x 5 xxxx xxxx    4096 20. Nov 07:27 branch-api
      drwxr-xr-x 4 xxxx xxxx    4096 20. Nov 07:27 durable-task
      drwxr-xr-x 4 xxxx xxxx    4096 20. Nov 07:27 display-url-api
      drwxr-xr-x 4 xxxx xxxx    4096 20. Nov 07:27 ssh-slaves
      

      Due to the unusable UI I'm neither able to revert the plugin update via thinBackup nor use jenkins at all.

      Any quick help is appreciated!

        Attachments

          Issue Links

            Activity

            greuelr Rene Greuel added a comment - - edited

            Same problem here. You can fix it temporarily by 

            • reverting the SSH-Slaves Plugin back to version 1.28.1 manually in the file system

            After a restart of jenkins my jobs are running well again.

            sime788 Simon Nicoll added a comment -

            Hi

            I just updated six test and development servers five on Jenkins version 2.138.3 and one on Jenkins version 2.89.4 three of the six servers have the same issue as above including the server on 2.89.4

            Will use Rene Greuel's fix for now.

            Thanks Rene!

            npfistner Norbert Pfistner added a comment -

            Reverting the ssh-slaves plugin did the job!

            Many thanks!

            You saved my day!

            sime788 Simon Nicoll added a comment -

            A little bit of help for those of you who don't know how to revert the ssh-slaves plugin if you are using Linux

            • go to where Jenkins is installed and make sure you are the correct user
            • cd plugins
            • ls la | grep ssh-slaves
            • mv ssh-slaves.jpi ssh-slaves.jpi.broken
            • mv ssh-slaves.bak ssh-slaves.jpi
            • restart jenkins

            This worked for me and hopefully you are back in business too!

             


              People

              • Assignee:
                ifernandezcalvo Ivan Fernandez Calvo
                Reporter:
                npfistner Norbert Pfistner
              • Votes:
                1 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: