Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-54854

Warning when trigger spent to much time in a cron execution

    Details

    • Type: Improvement
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Similar Issues:
    • Released As:
      Jenkins 2.189

      Description

      It would be nice make a warning to a log when Trigger spends too much time in Cron trigger.

      It ssually means a malfunction or other issue in a plug-in and timers initiated by defined crontab(s) aren't working correctly (at least when expected). Given Jenkins cron task design, trigger taking more than 60 seconds to complete can prevent task scheduled for the next minute to run on time.

        Attachments

          Issue Links

            Activity

            pajasoft Pavel Janoušek added a comment -

            PR sent.

            danielbeck Daniel Beck added a comment -

            "Cron is not working", often caused by Bitbucket doing networking in the trigger, is a pretty regular complaint, so

             


              People

              • Assignee:
                pajasoft Pavel Janoušek
                Reporter:
                pajasoft Pavel Janoušek
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: