Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-54926

reactive parameters are no longer reacting

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Cannot Reproduce
    • Component/s: active-choices-plugin
    • Labels:
      None
    • Environment:
      Jenkins ver. 2.138.3
      active choices plugin - 2.1
      windows server
    • Similar Issues:

      Description

      my reactive parameters have stopped reacting.  I believe it happend when I upgraded jenkins from 2.121.3

      I have an extenisible choice parameter(defaultbranchname) that gives me a list of values.  when I pick one of these values, a reactive parameter (branch for another repo) should be set to a value that matches the one picked in the extensible choice field.

      the groovy code is run when I initially execute Build with Parameters but it appears that the groovy code is not getting executed when I pick a different value for the default branch field.

      here is a picture of the initial page in jenkins:

        Attachments

          Activity

          mcote55 marlene cote added a comment -

          here is a picture of the results of changing the default branch field:  the other fields should be set to release/v0.3, but nothing happens.

          mcote55 marlene cote added a comment -

          sorry to waste your time.  you can close this.  the problem was that jenkins reverted my config file somehow to an old one.  the extensible choice parameter won't trigger the active choices reactive parameter.  I made it an active choices parameter instead, and it is working again.

          kinow Bruno P. Kinoshita added a comment -

          Not a problem marlene cote. But thanks a lot for updating the ticket's resolution, and also explaining what happened - which might be helpful to others with similar issues.

          Bruno

           


            People

            • Assignee:
              kinow Bruno P. Kinoshita
              Reporter:
              mcote55 marlene cote
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: