Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-56208

Problem with latest jenkins/jenkins:lts docker image

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open (View Workflow)
    • Priority: Minor
    • Resolution: Unresolved
    • Component/s: pipeline
    • Labels:
    • Environment:
      browser , suggested plugins installed
    • Similar Issues:

      Description

          1. Docker commands that you execute
            docker run -p 8080:8080 -p 50000:50000 -v jenkins_home:/var/jenkins_home jenkins/jenkins:lts
          1. Actual result
            After entering initial admin password, configuring plugins I create a multibranch pipeline project called test. The configure screen appears with the mention loading and the pulsating circle. It never stops. I cannot delete the job and I get an error:

        Attachments

        1. Capture.PNG
          Capture.PNG
          84 kB
        2. Capture2.PNG
          Capture2.PNG
          96 kB
        3. Capture3.PNG
          Capture3.PNG
          54 kB
        4. logs.log
          21 kB
        5. plugins.txt
          8 kB

          Activity

          Hide
          jenkinsuser99 john snow added a comment - - edited

          installing blue ocean plugin solves the half the problem, meaning that the loading screen goes away, 

          There is still no save button and I cannot delete the job.

          This is my docker initialization comand:

          docker run -u root --rm -d -p 8080:8080 -v jenkins-data:/var/jenkins_home -v /var/run/docker.sock:/var/run/docker.sock jenkins/jenkins

          Show
          jenkinsuser99 john snow added a comment - - edited installing blue ocean plugin solves the half the problem, meaning that the loading screen goes away,  There is still no save button and I cannot delete the job. This is my docker initialization comand: docker run -u root --rm -d -p 8080:8080 -v jenkins-data:/var/jenkins_home -v /var/run/docker.sock:/var/run/docker.sock jenkins/jenkins
          Hide
          oleg_nenashev Oleg Nenashev added a comment -

          "

          Caused by: java.lang.NoClassDefFoundError: com/cloudbees/hudson/plugins/folder/properties/FolderCredentialsProvider

           " in logs

          Show
          oleg_nenashev Oleg Nenashev added a comment - " Caused by: java.lang.NoClassDefFoundError: com/cloudbees/hudson/plugins/folder/properties/FolderCredentialsProvider  " in logs
          Hide
          oleg_nenashev Oleg Nenashev added a comment -

          john snowplease provide a full list of plugins installed on your instance

          Show
          oleg_nenashev Oleg Nenashev added a comment - john snow please provide a full list of plugins installed on your instance
          Hide
          jenkinsuser99 john snow added a comment -

          Hello,

          New to Docker

          It seems I made some mistakes and I am running latest Jenkins ver. 2.165 , instead of lts: 2.150.3(anyway I attached the plugin list).

          I didn`t know that not mentioning a label at the start of the container, starts it with label latest automatically.

           

          I deleted the jenkins:latest image and installed the lts one. Everything is ok.

          Thank you

           

          Show
          jenkinsuser99 john snow added a comment - Hello, New to Docker It seems I made some mistakes and I am running latest  Jenkins ver. 2.165 , instead of lts: 2.150.3(anyway I attached the plugin list). I didn`t know that not mentioning a label at the start of the container, starts it with label latest automatically.   I deleted the jenkins:latest image and installed the lts one. Everything is ok . Thank you  

            People

            • Assignee:
              Unassigned
              Reporter:
              jenkinsuser99 john snow
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated: