Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-56333

Error reported as warning (high) for pc-lint parser

    Details

    • Similar Issues:
    • Released As:
      5.0.0 (analysis-model and warnings-ng)

      Description

      Pretty much what the title says

      from the result output : 

      Error 46: field type should be _Bool, unsigned int or signed int [MISRA 2012 Rule 6.1, required]

       

      But in the plugin it's reported as warning (high), same for the quality gate.

       

      I've followed the format instruction:

      -v
      -width(0)
      -"format=%f(%l): %t %n: %m"
      -hs1

        Attachments

          Activity

          Hide
          drulli Ulli Hafner added a comment -

          Yes, not all parser have been updated to the new API yet.

          Show
          drulli Ulli Hafner added a comment - Yes, not all parser have been updated to the new API yet.
          Hide
          mwoua David Levy added a comment -

          Just ran basic tests, error is detected, build is correctly failed because of my quality gate. But in blue ocean, the step is still green, so its hard to detect where the fail comes from

          Show
          mwoua David Levy added a comment - Just ran basic tests, error is detected, build is correctly failed because of my quality gate. But in blue ocean, the step is still green, so its hard to detect where the fail comes from
          Hide
          drulli Ulli Hafner added a comment -

          This will be possible in the near future: see https://github.com/jenkinsci/warnings-ng-plugin/pull/58. I'm not sure when the UI side is being changed.

          Show
          drulli Ulli Hafner added a comment - This will be possible in the near future: see https://github.com/jenkinsci/warnings-ng-plugin/pull/58 . I'm not sure when the UI side is being changed.
          Hide
          jamberg Jens Amberg added a comment -

          Hello,

           

          I bring PC-Lint with the Warnings Next Generation Plugin 6.1.0 not to work. The old plugin works. Have somebody a hint for me?

          Show
          jamberg Jens Amberg added a comment - Hello,   I bring PC-Lint with the Warnings Next Generation Plugin 6.1.0 not to work. The old plugin works. Have somebody a hint for me?
          Hide
          drulli Ulli Hafner added a comment - - edited

          Jens Amberg: Please use the Gitter channel to ask questions.

          Show
          drulli Ulli Hafner added a comment - - edited Jens Amberg : Please use the Gitter channel to ask questions.

            People

            • Assignee:
              laebi Lorenz Aebi
              Reporter:
              mwoua David Levy
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: