Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-56537

Gitlab ID could not be found but is set and works

    Details

    • Type: Bug
    • Status: Open (View Workflow)
    • Priority: Minor
    • Resolution: Unresolved
    • Component/s: credentials-plugin
    • Labels:
    • Environment:
      Jenkins ver. 2.150.3

      Credentials Plugin 2.1.18
    • Similar Issues:

      Description

      I've updated my Jenkins installation to 2.150 and also plugins. I've set Gitlab token in Jenkins configuration and connection works without problem when I click on "Test connection" button.

      When I launch a pipeline Job, repository is correctly pulled but I've the following warning in console output:

      Warning: CredentialId "RENO-Gitlab" could not be found.
      

      Here is my pipeline code:

       checkout([
         $class: 'GitSCM',
          branches: [[name: "origin/dev"]],
          userRemoteConfigs: [[credentialsId: 'RENO-Gitlab', url: 'git@mygitlab.group/project.git']]
      ])
      

      So the Job starts well and works but this warning is displayed.

        Attachments

          Activity

          There are no comments yet on this issue.

            People

            • Assignee:
              Unassigned
              Reporter:
              algorys Estrada Matthieu
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated: