Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-56864

"No certificate available" pop up is displayed when executing functional tests from Micro Focus ALM

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Fixed but Unreleased (View Workflow)
    • Priority: Critical
    • Resolution: Fixed
    • Labels:
    • Environment:
      Jenkins ver 2.7.4
      Micro Focus Application Automation Tools plugin 5.7.1-beta
      Micro Focus 12.53
      Micro Focus UFT 14.5
    • Similar Issues:

      Description

      "No certificate available" popup is displayed on slave machine when we build job for executing functional tests from Micro Focus ALM. I tried clicking "OK" button and job failed. I tried clicking "Cancel" button and job failed. I also tried not to confirm the popup, job failed because timeout was reached. Below is the failed message in console output. Kindly advise! Thanks!

      Id: 195, Execution status: Running
      Id: 195, Execution status: Unknown, Message: Unable to connect the testing tool to the requested ALM/QC server.

        Attachments

          Activity

          Hide
          aslaakso Anda Sorina Laakso added a comment -

          The error message you get to me seems to be from ALM. As I see from the description you are using version 12.53 of ALM. Have you considered upgrading it?

          Can you provide me also with the console logs you get when running the tests?

          Thank you.

          Show
          aslaakso Anda Sorina Laakso added a comment - The error message you get to me seems to be from ALM. As I see from the description you are using version 12.53 of ALM. Have you considered upgrading it? Can you provide me also with the console logs you get when running the tests? Thank you.
          Hide
          miliemanalo Milagros Manalo added a comment -

          We have plan to upgrade ALM to 12.6 by next year due to an application dependency. I attached props* file and console output file.  I followed all prerequisites before I manually trigger job. Please let me know should you need more details. Thanks!

          [^props29032019142627075.txt]

          Show
          miliemanalo Milagros Manalo added a comment - We have plan to upgrade ALM to 12.6 by next year due to an application dependency. I attached props* file and console output file.  I followed all prerequisites before I manually trigger job. Please let me know should you need more details. Thanks! [^props29032019142627075.txt]
          Hide
          aslaakso Anda Sorina Laakso added a comment -

          Do the following:

          • Open IE as administrator (right-click IE > Run as Administrator) and navigated to ALM Tools.
          • From the ALM Tools page, select "HP ALM Connectivity" and download/run on the affected client machine.
          • You should receive an "Installation Successful" message.
          • From the ALM Tools page select "HP ALM Client Registration" and "Register HP ALM." Click on "Register HP ALM" to register the ALM client.
          • Log into your ALM Client to make sure that works.

          After registering ALM rerun the tests.

          Show
          aslaakso Anda Sorina Laakso added a comment - Do the following: Open IE as administrator (right-click IE > Run as Administrator) and navigated to ALM Tools. From the ALM Tools page, select "HP ALM Connectivity" and download/run on the affected client machine. You should receive an "Installation Successful" message. From the ALM Tools page select "HP ALM Client Registration" and "Register HP ALM." Click on "Register HP ALM" to register the ALM client. Log into your ALM Client to make sure that works. After registering ALM rerun the tests.
          Hide
          miliemanalo Milagros Manalo added a comment -

          We updated ALM server in plugin from https://<ALM IP>/qcbin to https://<ALM URL>/qcbin. As per MicroFocus support team, the scripts works with the IP address but that causes issues when using HTTPS since the certificate uses the hostname. Issue is resolved. Thank you for looking into this issue.

          Show
          miliemanalo Milagros Manalo added a comment - We updated ALM server in plugin from https://<ALM IP>/qcbin to https://<ALM URL>/qcbin. As per MicroFocus support team, the scripts works with the IP address but that causes issues when using HTTPS since the certificate uses the hostname. Issue is resolved. Thank you for looking into this issue.

            People

            • Assignee:
              aslaakso Anda Sorina Laakso
              Reporter:
              miliemanalo Milagros Manalo
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: