Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-57158

Pipeline is green but shows red in stage view

    Details

    • Similar Issues:

      Description

      We had a build complete successfully; it shows green when viewing the details for that particular build and in the list of builds for that job. However, in the stage view for the job, that particular build shows red. Screenshot attached.

        Attachments

          Issue Links

            Activity

            Hide
            chanukov Alon Chanukov added a comment - - edited

            I also had this reported to me in prod twice in the 24 hours since I upgraded to latest started happening after we took in the Jenkins LTS.

            This has happened with both regular pipeline and multi branch
            we upgradedĀ 
            pipeline-stage-tags-metadata 1.3.2
            pipeline-stage-view 2.10
            On Smithers Staging pipeline-stage-tags-metadata 1.3.8
            On Smithers Staging pipeline-stage-view 2.11
            among many other plugins, though those seem most applicable
            We also moved from 2.89.3 LTS to 2.164.3LTS

            Show
            chanukov Alon Chanukov added a comment - - edited I also had this reported to me in prod twice in the 24 hours since I upgraded to latest started happening after we took in the Jenkins LTS. This has happened with both regular pipeline and multi branch we upgradedĀ  pipeline-stage-tags-metadata 1.3.2 pipeline-stage-view 2.10 On Smithers Staging pipeline-stage-tags-metadata 1.3.8 On Smithers Staging pipeline-stage-view 2.11 among many other plugins, though those seem most applicable We also moved from 2.89.3 LTS to 2.164.3LTS
            Hide
            djviking Sverre Moe added a comment -

            We have noticed the same on our Multibranch pipelines. All stages are good, but Stage View still shows the build as failed. It is very rare when it occurs.

            Show
            djviking Sverre Moe added a comment - We have noticed the same on our Multibranch pipelines. All stages are good, but Stage View still shows the build as failed. It is very rare when it occurs.
            Hide
            jons Jon Sten added a comment -

            A user ran into the same problem. I did some quick debugging and it the problem is not on the client side. The rest API call incorrectly reports back failure. On the server side I found that calling RunExt.createNew() provides a RunExt with correct status, while RunExt.create() returns a cached RunExt with its status set to failure. I have no idea how that RunExt with incorrect status ended up in the cache. Would be interesting to know it it was had failure status when initially created or had success as initial result but the field was altered by some other code. No one knows...

            Show
            jons Jon Sten added a comment - A user ran into the same problem. I did some quick debugging and it the problem is not on the client side. The rest API call incorrectly reports back failure. On the server side I found that calling RunExt.createNew() provides a RunExt with correct status, while RunExt.create() returns a cached RunExt with its status set to failure. I have no idea how that RunExt with incorrect status ended up in the cache. Would be interesting to know it it was had failure status when initially created or had success as initial result but the field was altered by some other code. No one knows...
            Hide
            slonopotamusorama Marat Radchenko added a comment -

            Duplicate of JENKINS-43556

            Show
            slonopotamusorama Marat Radchenko added a comment - Duplicate of JENKINS-43556

              People

              • Assignee:
                svanoort Sam Van Oort
                Reporter:
                carej Jeff Care
              • Votes:
                6 Vote for this issue
                Watchers:
                9 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: