Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-5786

Global MAVEN_OPTS is not propagate to job settings

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Won't Fix
    • Component/s: maven-plugin
    • Labels:
      None
    • Environment:
      Server:
      * Linux 2.6.27.19-5-default #1 SMP 2009-02-28 04:40:21 +0100 x86_64 x86_64 x86_64 GNU/Linux
      * Tomcat 6.0.24
      * java version "1.6.0_18"
      * Hudson server: 1.348
    • Similar Issues:

      Description

      • I set in global configuration of MAVEN_OPTS parameter: -Xmx512M -XX:MaxPermSize=128M
      • In job configuration have next additional parameteres -Djavax.net.ssl.trustStore="${M2_LOCAL}/cacerts"

      Result of called build is:

      [trunk] $ java -Djavax.net.ssl.trustStore=D:/var/hudson-slave/.m2/cacerts -cp d:\var\hudson-slave\maven-agent.jar;d:\var\hudson-slave\tools\apache-maven-2.2.1\boot\classworlds-1.1.jar hudson.maven.agent.Main d:\var\hudson-slave\tools\apache-maven-2.2.1 D:\var\hudson-slave\slave.jar d:\var\hudson-slave\maven-interceptor.jar 2027 d:\var\hudson-slave\maven2.1-interceptor.jar
      <===[HUDSON REMOTING CAPACITY]===>
      channel started
      Executing Maven:  -B -f d:\var\hudson-slave\workspace\case-tool\trunk\pom.xml clean verify -Prelease,run-its

        Attachments

          Activity

          mdonohue mdonohue added a comment -

          This is by design, otherwise it would be impossible to have a job where you want to remove one of the global maven opts

          abayer Andrew Bayer added a comment -

          As mdonohue said, this is by design.


            People

            • Assignee:
              Unassigned
              Reporter:
              pprochazka pprochazka
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: