Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-59104

Custom tags are not published after upgrade of plugin Influx DB 2.0

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: influxdb-plugin
    • Labels:
      None
    • Environment:
      influxdb = 2.0
      Jenkins = 2.190
    • Similar Issues:
    • Released As:
      2.0.1

      Description

      After upgrading from 1.23 to latest 2.0 version of Influx DB the custom tags I was setting using jenkinsEnvParameterTag are being ignored and no longer being published.

      I am using the pipeline like below:

      influxDbPublisher([
        selectedTarget: 'influxdb_maint',
        customPrefix: '',
        customProjectName: '_',
        replaceDashWithUnderscore: true,
        jenkinsEnvParameterTag: "key1=value1\nkey2=value2\nkey3=value3"
      ])
      

      This works on 1.23 but not in 2.0.

      I have downgraded the plugin in order to work again.

      I am not sure why it's happening, but I know some refactoring's were done in the code that parses jenkinsEnvParameterTag.

       

        Attachments

          Activity

          aleksisimell Aleksi Simell added a comment -

          Issue is now fixed and will be available in the next release.

          Root cause was initialization error when calling from a pipeline. The generators worked correctly, so this was not caught by tests. Thanks for informing this so quickly!


            People

            • Assignee:
              aleksisimell Aleksi Simell
              Reporter:
              michelzanini Michel Zanini
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: