Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-59151

Blue ocean nodes are not marked red when parallel stage fails

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Cannot Reproduce
    • Component/s: blueocean-plugin, pipeline
    • Labels:
      None
    • Environment:
      Jenkins 2.176.2
      Blueocean 1.7.2
    • Similar Issues:

      Description

      pipeline {
          agent none
          stages {
              stage('Stage 1') {
                  steps {
                      echo "Stage 1"
                  }
              }
              stage('Parallel Stage') {
                  parallel {
                      stage('Stage 2') {
                          stages {
                              stage ('Stage 2.1') {
                                  steps {
                                      echo "Stage 2.1"
                                  }
                              }
                              
                              stage ('Stage 2.2') {
                                  steps {
                                      script {
                                          def parallelStage2 = [:]
                                          
                                          parallelStage2['Stage 2.2.1'] = {
                                              echo "Stage 2.2.1"
                                          }
                              
                                          parallelStage2['Stage 2.2.2'] = {
                                              echo "Stage 2.2.2"
                                          }
                                      
                                          parallel parallelStage2
                                      }
                                  }
                              }
                          }
                      }
                      stage('Stage 3') {
                          stages {
                              stage ('Stage 3.1') {
                                  steps {
                                      echo "Stage 3.1"
                                  }
                              }
                              
                              stage ('Stage 3.2') {
                                  steps {
                                      script {
                                          def parallelStage3 = [:]
                                          
                                          parallelStage3['Stage 3.2.1'] = {
                                              echo "Stage 3.2.1"
                                          }
                              
                                          parallelStage3['Stage 3.2.2'] = {
                                              echo "Stage 3.2.2"
                                              error("Intentional Failure")
                                          }
                                      
                                          parallel parallelStage3
                                      }
                                  }
                              }
                          }
                      }
                      
                  }
              }
          }
      }
      
      

      Using the above pipeline code snippet.  When a parallel stage is failed, blue ocean does not mark the node as red.  We have to click through each node during the parallel stage to figure out which stage the job failed at.

       

      Expected behavior should mark the Stage as red within the Blue Ocean UI.

       

        Attachments

          Activity

          v2v Victor Martinez added a comment -

          That particular pipeline works as expected in my case based on (see the below screenshot):

          • Blue Ocean 1.18.1
          • Jenkins Core 2.176.2

          I'd recommend upgrading the version of Blue Ocean as it seems this particular behaviour doesn't happen with newer versions.

          vivek Vivek Pandey added a comment -

          Looks like this has been fixed. Please try blueocean 1.18.1 or greater.


            People

            • Assignee:
              Unassigned
              Reporter:
              jacksod1 David Jackson
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: