Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-59754

Jenkins Micro Focus Application Automation Tools Plugin losing connection with Octane after running pipelines

    Details

    • Similar Issues:

      Description

      We have configured Octane / Jenkins integration by installing ALM Octane plugin in Jenkins. The connection works for a day and then drops.

      Jenkins is setup as a CI server in Octane, we have found that if we run a pipeline everyday with a Jenkins build that the connection between Jenkins and Octane drops and the Jenkins plugin for Octane cannot get a new connection to the Octane server.

      A few things we have noticed:

      The issue only happens if we run a build once a day, if we have a pipeline running every hour the issue does not seem to happen. We believe that the plugin may not be managing the sessions (cookies/tokens) with Octane correctly and that by running a build every hour might be keeping the session "alive"

      When this happens our only fix seems to be restarting the Jenkins server which we think might make the plugin renegotiate the session with Octane

      We tried the newest plugin 5.9 to see if it might resolve the issue but it did not

        Attachments

          Activity

          Show
          radislavb Radi Berkovich added a comment - Please use v5.9.2-beta :  http://repo.jenkins-ci.org/releases/org/jenkins-ci/plugins/hp-application-automation-tools-plugin/5.9.2-beta/hp-application-automation-tools-plugin-5.9.2-beta.hpi  
          Hide
          radislavb Radi Berkovich added a comment -

          please update me if you already used 5.9.2

          .

          Show
          radislavb Radi Berkovich added a comment - please update me if you already used 5.9.2 .
          Hide
          radislavb Radi Berkovich added a comment -

          If you still didn't installed previous link, please you this :

          (its the same code, it just official beta version)

          http://repo.jenkins-ci.org/releases/org/jenkins-ci/plugins/hp-application-automation-tools-plugin/5.9.3-beta/hp-application-automation-tools-plugin-5.9.3-beta.hpi

           

          Show
          radislavb Radi Berkovich added a comment - If you still didn't installed previous link, please you this : (its the same code, it just official beta version) http://repo.jenkins-ci.org/releases/org/jenkins-ci/plugins/hp-application-automation-tools-plugin/5.9.3-beta/hp-application-automation-tools-plugin-5.9.3-beta.hpi  
          Hide
          radislavb Radi Berkovich added a comment -

          any updates?

          Show
          radislavb Radi Berkovich added a comment - any updates?
          Hide
          radislavb Radi Berkovich added a comment - - edited

          Official version 6.0 is released .

          Please check if issue is reproduced on this version.

          Show
          radislavb Radi Berkovich added a comment - - edited Official version 6.0 is released . Please check if issue is reproduced on this version.

            People

            • Assignee:
              radislavb Radi Berkovich
              Reporter:
              jmyates86 Joshua Yates
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: