Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-59889

Cannot start new Jenkins with agent.jar file

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Not A Defect
    • Component/s: remoting
    • Labels:
      None
    • Similar Issues:

      Description

      I'm trying to connect VM with Jenkins remote but when I execute this:

      java -jar c:\jenkins\agent.jar -jnlpUrl http://vmname:port/computer/VMHOST/slave-agent.jnlp

      There is error:

       X 22, 2019 5:12:45 PM hudson.remoting.UserRequest perform
      WARNING: LinkageError while performing UserRequest:hudson.node_monitors.SwapSpaceMonitor$MonitorTask@475deef7
      java.lang.NoClassDefFoundError: Could not initialize class com.sun.jna.Native
      at com.sun.jna.Structure.setAlignType(Structure.java:280)
      at com.sun.jna.Structure.<init>(Structure.java:197)

       

      I'm using Windows 10 Server and Java 1.8.0.112

        Attachments

          Activity

          jthompson Jeff Thompson added a comment -

          This is a weird one and I don't have any suggestions for you. There was a recent update to the jna library in Jenkins core, but that doesn't explain why you are seeing this behavior. Some discussion on the web about this error with JNA involves permissions or capacity on a temp dir, but that seems to be more focused on Unix OSes. You might try to reproduce this on other machines if you can and see if it's specific to just that one instance. Other people haven't reported this issue so it might just be a machine issue.

          You could try posting in the Jenkins user email list or gitter channel and see if anyone else has seen anything like this.

          rjenkins Rumen Angelov added a comment -

          It was java problem. There were missing java temp files, after clean installation - the problem was solved 

          jthompson Jeff Thompson added a comment -

          I'm glad you were able to figure that out. Thanks for updating this – in case someone else sees a similar problem they could learn from this.


            People

            • Assignee:
              jthompson Jeff Thompson
              Reporter:
              rjenkins Rumen Angelov
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: