Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-60203

Git client plugin 3.0 fails to load trilead class with old Java 8

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Cannot Reproduce
    • Component/s: git-plugin
    • Labels:
    • Environment:
      Jenkins (2.190.2) running on Windows Server
      Git Plugin 4.0
      Firefox Browser
    • Similar Issues:

      Description

      We have been running Jenkins and pulling using Git.  Updated Git plugin from 3.12.1 to version 4.0.0.  We now see these two errors when attempting to pull using Git.

        Attachments

          Issue Links

            Activity

            markewaite Mark Waite added a comment -

            You'll need to install the "trilead-api" plugin on your Jenkins instance. The trilead-api plugin was extracted from Jenkins core in Jenkins 2.190. Plugins cannot make the trilead-api plugin an explicit dependency without breaking their use on Jenkins versions before 2.190. The git plugin and git client plugin must continue to support Jenkins users on versions prior to 2.190.
            Thankfully, many users already have the trilead-api plugin installed, so they do not see any problem even with 2.190.

            Install the trilead-api plugin on your Jenkins instance.

            charbl Larry charbonneau added a comment -

            We have the Trilead API Plugin installed.

            markewaite Mark Waite added a comment -

            Have you installed git client plugin 3.0.0 when you installed git plugin 4.0.0? I assume yes, but since incomplete configuration information is provided in the report, I can't be sure.

            I assume you're running one of the versions of Java 8 that is available for Windows. Which Java version is it? Which Java provider (Oracle, OpenJDK, AdoptOpenJDK, Amazon Corretto, etc.)?

            If it is an older Java 8 version, can you try a more recent Java version on a different machine to see if it resolves the issue?

            If it is a Java 11 version, can you try a Java 8 version on a different machine to see if it resolves the issue?

            I doubt that the Windows Server version is relevant, but just in case, what is the Windows Server version?

            I doubt that the Windows Server feature release is relevant, but just in case, what Windows Server feature release are you using? I regularly test agents with Windows 10.0.1903 and have tested previously with Windows 10.0.1809.

            Incomplete information and screenshots of text are making it more difficult for me to help with this report. Can you provide more detailed configuration information?

            charbl Larry charbonneau added a comment -

            Java on server: 1.8.0_101 (Oracle)

            Windows Server 2016

            Git on server: 2.24.0.windows.2

            Have Git client Plugin 3.0 installed

             

             

            markewaite Mark Waite added a comment -

            Java 1.8.0_101 is almost 4 years old (January 2016). The current version is Java 1.8.0_232. There were significant changes in Java 1.8.0 in the 150 / 160 timeframe. I don't know if those changes will affect this issue or not.

            I'm not aware of any Jenkins developers that test with a Java 8 version which is that old. Even if it does not resolve this issue, you're likely to have a better experience with Jenkins if you're running a current Java version (either OpenJDK or AdoptOpenJDK).

            Since you're running the most recent command line git on your Windows Server, I assume you're also able to update to the latest AdoptOpenJDK or OpenJDK version.

            Are you able to duplicate the same problem on another computer?

            Can you provide the detailed configuration you used to duplicate the problem?

            markewaite Mark Waite added a comment -

            Larry charbonneau have you been able to resolve this issue on your Windows server?

            markewaite Mark Waite added a comment -

            Cannot duplicate, no response from submitter


              People

              • Assignee:
                Unassigned
                Reporter:
                charbl Larry charbonneau
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: