Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-60536

Jenkins job hangs in Jira call after git rev-list command

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Fixed
    • Component/s: jira-plugin
    • Labels:
    • Environment:
    • Similar Issues:

      Description

      Recently Jenkins master  when a job is triggered it hangs around checkout

       Command that it seems to get stuck on:

      git rev-list --no-walk a4539ebbe8fe6da843fb1fe4c7b0ce5cf79a0647 # timeout=10 

      This issue only started happening sporadically from 2019-12-17 and is impacting our CI/CD pipeline. We rely on Jenkins to deploy to our environments.

       

      If you tried to kill the job, it is unresponsive.

      If you restart Jenkins master then the job that gets stuck is no longer exists

       

      Job Build Logs:

      Started by upstream project "parent-job" build number 5
      originally caused by:
       Branch indexing
      Checking out git <REPO> into /var/lib/jenkins/workspace/acceptance-tests@script to read acceptance-tests/Jenkinsfile-local
      using credential jenkins-git
       > git rev-parse --is-inside-work-tree # timeout=10
      Fetching changes from the remote Git repository
       > git config remote.origin.url git@bitbucket.org:obillex/fundit.git # timeout=10
      Fetching upstream changes from git@bitbucket.org:obillex/fundit.git
       > git --version # timeout=10
      using GIT_SSH to set credentials Jenkins access to git
       > git fetch --tags --progress -- <REPO>+refs/heads/*:refs/remotes/origin/* # timeout=10
       > git rev-parse b6a1b7a159b86dd5a52b8385670397d568345c53^{commit} # timeout=10
      Checking out Revision b6a1b7a159b86dd5a52b8385670397d568345c53 (detached)
       > git config core.sparsecheckout # timeout=10
       > git checkout -f b6a1b7a159b86dd5a52b8385670397d568345c53 # timeout=10
      Commit message: "Commit message"
       > git rev-list --no-walk a4539ebbe8fe6da843fb1fe4c7b0ce5cf79a0647 # timeout=10

      This issue seems to be a regression of this resolved issue JENKINS-43106

        Attachments

          Issue Links

            Activity

            falcon benoit guerin added a comment -

            Agreed, issue is still present

            hsanson Hugo SANSON added a comment - - edited

            Using this fork you guys made at https://github.com/xft-devs/jira-plugin

            The issue looks fixed or at least
            Our use cases with Jenkins pipeline JiraSearch and JiraIssueUpdater against Jira Cloud work fine.
            No more threads hanging or blocked

             To be able to build this fork, i had to change a few versions in the pom.xml

            configuration-as-code.version from 1.8 to 1.36
            jackson2-api from 2.8.11.2 to 2.10.2
            io.jenkins.configuration-as-code to io.jenkins.configuration-as-code.test-harness
            junit from 1.3 to 1.20
            org.jenkins-ci.plugins.credentials from 2.1.19 to 2.2.1
            

            These versions changes match the https://github.com/jenkinsci/jira-plugin branch feature/4.0 changes

            falcon benoit guerin added a comment -

            Same here, modifications from xft-devs solve issue. Thanks to them !

            I rebase theirs changes on master, here is the PR : https://github.com/jenkinsci/jira-plugin/pull/230

            dscheidt David Scheidt added a comment -

            Is there any timeline on when the changes in  https://github.com/jenkinsci/jira-plugin/pull/230 will be released?  Not being able to integrate with Jira is big limitation in our workflow.

            dfrance David France added a comment -

            Pleased to report this was looking stable just now. This was with the 3.0.17 release. Many thanks.


              People

              • Assignee:
                olamy Olivier Lamy
                Reporter:
                honestem Emma Phillips
              • Votes:
                8 Vote for this issue
                Watchers:
                11 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: