Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-6070

Hudson Backup Failed trying to read filesystem attributes for a .gif file

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: backup-plugin
    • Labels:
      None
    • Environment:
      Linux: RHEL5.2
      Hudson: 1.351
      backup: 1.4.1
    • Similar Issues:

      Description

      Tried running the backup for the first time to a local hard drive. Failed without creating a backup file. Plenty of space on the device.

      Here is the trace:

      [ INFO] Backup started at [03/25/10 15:31:51]
      [ INFO] Setting hudson in shutdown mode to avoid files corruptions.
      [ INFO] Waiting all jobs end...
      [ INFO] Number of running jobs detected : 0
      [ INFO] All jobs finished.
      [ INFO] Full backup file name : /backups/hudson/backup_20100325_1531.tar.bz2
      [ERROR] org.codehaus.plexus.archiver.ArchiverException: Failed to read filesystem attributes for: /var/lib/hudson/war/images/24x24/
      grey_anime.gif

      org.jvnet.hudson.plugins.backup.BackupException: java.io.IOException: Unable to add war/images/24x24/grey_anime.gif at org.jvnet.hudson.plugins.backup.utils.BackupEngine.doBackup(BackupEngine.java:115) at org.jvnet.hudson.plugins.backup.utils.BackupTask.run(BackupTask.java:125) at java.lang.Thread.run(Thread.java:636)

      Caused by: java.io.IOException: Unable to add war/images/24x24/grey_anime.gif at org.jvnet.hudson.plugins.backup.utils.BackupEngine.handleFile(BackupEngine.java:90) at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:367) at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:364) at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:364) at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:364) at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:335) at org.jvnet.hudson.plugins.backup.utils.BackupEngine.doBackup(BackupEngine.java:113) ... 2 more
      [ INFO] Cancel hudson shutdown mode
      [ INFO] Backup end at [03/25/10 15:32:43]
      [ INFO] [51.345s]

        Attachments

          Issue Links

            Activity

            sauravsengupta sauravsengupta added a comment -

            I'm seeing this too:

            [ERROR] org.codehaus.plexus.archiver.ArchiverException: Failed to read filesystem attributes for: /.../hudson/war/images/16x16/person.gif
            org.jvnet.hudson.plugins.backup.BackupException: java.io.IOException: Unable to add war/images/16x16/person.gif
            	at org.jvnet.hudson.plugins.backup.utils.BackupEngine.doBackup(BackupEngine.java:115)
            	at org.jvnet.hudson.plugins.backup.utils.BackupTask.run(BackupTask.java:125)
            	at java.lang.Thread.run(Thread.java:619)
            Caused by: java.io.IOException: Unable to add war/images/16x16/person.gif
            	at org.jvnet.hudson.plugins.backup.utils.BackupEngine.handleFile(BackupEngine.java:90)
            	at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:367)
            	at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:364)
            	at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:364)
            	at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:364)
            	at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:335)
            	at org.jvnet.hudson.plugins.backup.utils.BackupEngine.doBackup(BackupEngine.java:113)
            	... 2 more
            [ INFO] Cancel hudson shutdown mode
            [ INFO] Backup end at [10/18/10 12:46:58]
            [ INFO] [185.617s]
            

            It seems to happen on a random file each time. This is a new Hudson master, running in glassfish, on Ubuntu, and this is the first time I attempted a backup on this master. The old Hudson master was running as a service under Windows XP, and that worked fine. FWIW, I'm trying to write to an NFS share, and I've verified that the user has write permissions to the share.

            rseguy Romain Seguy added a comment -

            Duplicates JENKINS-5968


              People

              • Assignee:
                Unassigned
                Reporter:
                rayward rayward
              • Votes:
                1 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: