Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-61697

Cannot contact node: java.lang.InterruptedException

    Details

    • Similar Issues:

      Description

      Hi,

       

      We are experiencing the following error when running pipeline jobs:

      // Cannot contact node: java.lang.InterruptedException
      

      I came across these issues and both suggests upgrading the pipeline plugins:
      https://issues.jenkins-ci.org/browse/JENKINS-43038

      https://issues.jenkins-ci.org/browse/JENKINS-46507

       

      However, I'm hesitant to upgrade due to all the related dependencies that need to be upgraded as well.

       

      1. Can you confirm which plugin needs to be upgraded? There are several "pipeline" related plugins

       

      Ive attached a support bundle for one of the jobs that failed for this reason. Would appreciate if anyone can take a look

        Attachments

          Issue Links

            Activity

            Hide
            ifernandezcalvo Ivan Fernandez Calvo added a comment -

            the short answer is yes if you have a version with more than 6 months a year, there is a lot of improvements relates to stability, log reporting, remoting, ... , the long answer is Which Jenkins core version you have and with plugin version you have, then if you core version is old the problem it is to upgrade a whole Jenkins instance and all the jobs and plugins related, so I'd suggest taking the time and test everything on a test environment and when you are confident make the upgrade.
            In any case, this is more a support question not an issue please use the google groups for that. https://wiki.jenkins.io/display/JENKINS/How+to+report+an+issue

            Show
            ifernandezcalvo Ivan Fernandez Calvo added a comment - the short answer is yes if you have a version with more than 6 months a year, there is a lot of improvements relates to stability, log reporting, remoting, ... , the long answer is Which Jenkins core version you have and with plugin version you have, then if you core version is old the problem it is to upgrade a whole Jenkins instance and all the jobs and plugins related, so I'd suggest taking the time and test everything on a test environment and when you are confident make the upgrade. In any case, this is more a support question not an issue please use the google groups for that. https://wiki.jenkins.io/display/JENKINS/How+to+report+an+issue

              People

              • Assignee:
                ifernandezcalvo Ivan Fernandez Calvo
                Reporter:
                evan Evan Arbeitman
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: