Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-62463

Push trigger is not starting a pipelines build

    Details

    • Similar Issues:

      Description

      I've followed an example how to set pipelines project using this video: https://www.youtube.com/watch?v=0-FugzVYJQU . Bitbucket webhook is created, and it notifies jenkins, however jenkins does nothing after receiving it. I see the following lines in the log:

      May 26, 2020 2:02:40 PM FINE com.atlassian.bitbucket.jenkins.internal.trigger.BitbucketWebhookEndpoint
      Payload: com.atlassian.bitbucket.jenkins.internal.trigger.RefsChangedWebhookEvent@3a67ec4d
      May 26, 2020 2:02:40 PM FINE com.atlassian.bitbucket.jenkins.internal.trigger.BitbucketWebhookConsumer
      {{Received refs changed event from repo: PROJ/acs }}
      May 26, 2020 2:02:40 PM FINE com.atlassian.bitbucket.jenkins.internal.trigger.BitbucketWebhookConsumer
      Triggering project » ACS

       

      Pipeline is set to build from Jenkinsfile and from any branch (branch selector set to: **). Build trigger is set to: Bitbucket Server trigger build after push

        Attachments

          Activity

          Hide
          alibkord Ali Kord added a comment -

          Hi Rapolas K.,

          We were not able to reproduce this in our tests. Can you please provide more details about your environment and configuration?

          Which versions of Bitbucket Server, Jenkins, and the Bitbucket Server Integration plugin are you using?

          Can you please provide the details of your Bitbucket SCM configuration (under Jenkins System Configs), as well as the details of the pipeline build config (e.g. screenshots if possible)?

          Are there any errors or warnings in Jenkins logs after Jenkins receives the trigger from the webhook?

          Can the build be manually triggered and does it successfully complete?

          Does re-saving the pipeline config solve the problem?

          Thanks,

          Ali Kord

          Show
          alibkord Ali Kord added a comment - Hi Rapolas K. , We were not able to reproduce this in our tests. Can you please provide more details about your environment and configuration? Which versions of Bitbucket Server, Jenkins, and the Bitbucket Server Integration plugin are you using? Can you please provide the details of your Bitbucket SCM configuration (under Jenkins System Configs), as well as the details of the pipeline build config (e.g. screenshots if possible)? Are there any errors or warnings in Jenkins logs after Jenkins receives the trigger from the webhook? Can the build be manually triggered and does it successfully complete? Does re-saving the pipeline config solve the problem? Thanks, Ali Kord

            People

            • Assignee:
              alibkord Ali Kord
              Reporter:
              rapolas Rapolas K.
            • Votes:
              1 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: