Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-62706

After updating to 3.1.0 'Update relevant issues' stopped working

    Details

    • Type: Bug
    • Status: Open (View Workflow)
    • Priority: Major
    • Resolution: Unresolved
    • Component/s: jira-plugin
    • Labels:
      None
    • Environment:
      Jenkins 2.230-2.242
      Plugin 3.1.0-3.1.1
    • Similar Issues:

      Description

      updating from 3.0.18 to 3.1.0, 'Update relevant issues' makes the build fail with error:

      [Jira] The system configuration does not allow remote Jira access

      The configuration (in Jenkins and in the job) didn't change and before the update it worked correctly.

       

       

      Logging of 'hudson.plugins.jira':

      Jun 17, 2020 10:57:15 AM FINE hudson.plugins.jira.selector.DefaultIssueSelectorLooking for Jira ID in AB-1234 : jira commit message test
      Jun 17, 2020 10:57:20 AM FINE hudson.plugins.jira.JiraChangeLogAnnotatorUsing site: [SITE URL]
      Jun 17, 2020 10:57:20 AM FINE hudson.plugins.jira.JiraChangeLogAnnotatorUsing issue pattern: ([a-zA-Z][a-zA-Z0-9_]+-[1-9][0-9]*)([^.]|\.[^0-9]|\.$|$)
      Jun 17, 2020 10:57:20 AM INFO hudson.plugins.jira.JiraChangeLogAnnotator annotateNo known Jira project corresponding to id: 'AB-1234'

        Attachments

          Issue Links

            Activity

            Hide
            joseph_witthuhn Joseph Witthuhn added a comment -

            We saw the same issue on Jenkins 2.242 when updating the plugin from 3.0.18 to 3.1.1, causing all of our builds to fail. Reverting the plug-in upgrade resolved the issue.

            Show
            joseph_witthuhn Joseph Witthuhn added a comment - We saw the same issue on Jenkins 2.242 when updating the plugin from 3.0.18 to 3.1.1, causing all of our builds to fail. Reverting the plug-in upgrade resolved the issue.
            Hide
            joseph_witthuhn Joseph Witthuhn added a comment -

            Also, marking this major since it causes builds to fail with no known workaround (besides not using the plug-in or using an older version). I haven't reported too many issues here, so if this isn't the correct priority, please feel free to revert.

            Show
            joseph_witthuhn Joseph Witthuhn added a comment - Also, marking this major since it causes builds to fail with no known workaround (besides not using the plug-in or using an older version). I haven't reported too many issues here, so if this isn't the correct priority, please feel free to revert.
            Hide
            ashishk Ashish Kulkarni added a comment -

            Same here, downgrading to 3.0.18 fixes the issue.

            Show
            ashishk Ashish Kulkarni added a comment - Same here, downgrading to 3.0.18 fixes the issue.
            Hide
            patriks Patrik Schalin added a comment -

            Same here, downgraded to 3.0.18 and we were back up running.

            Jenkins 2.242

            Show
            patriks Patrik Schalin added a comment - Same here, downgraded to 3.0.18 and we were back up running. Jenkins 2.242

              People

              • Assignee:
                Unassigned
                Reporter:
                ricktw Rick Oosterholt
              • Votes:
                6 Vote for this issue
                Watchers:
                7 Start watching this issue

                Dates

                • Created:
                  Updated: