Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-6593

Violations plugin fails while reading Simian.XML.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Won't Fix
    • Component/s: violations-plugin
    • Labels:
      None
    • Environment:
      Hudson running Master-Slave on Windows servers with 4 GB RAM, 4 CPUs.
    • Similar Issues:

      Description

      Violations plugin error at end of build when reading Simian.XML.

      It seems the violations plugin is unable to handle code which contains HTML formatting text even after the fact Simian wrapped that block in a CDATA.

      ERROR: Publisher hudson.plugins.violations.ViolationsPublisher aborted due to exception
      hudson.util.IOException2: remote file operation failed: D:\HudsonWorkingDirectorySlave4\workspace\FileCabinet_Prj2 at hudson.remoting.Channel@fb0b1f:Slave4
      at hudson.FilePath.act(FilePath.java:752)
      at hudson.FilePath.act(FilePath.java:738)
      at hudson.plugins.violations.ViolationsPublisher.perform(ViolationsPublisher.java:74)
      at hudson.tasks.BuildStepMonitor$3.perform(BuildStepMonitor.java:36)
      at hudson.model.AbstractBuild$AbstractRunner.perform(AbstractBuild.java:601)
      at hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuild.java:580)
      at hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuild.java:558)
      at hudson.model.Build$RunnerImpl.post2(Build.java:158)
      at hudson.model.AbstractBuild$AbstractRunner.post(AbstractBuild.java:528)
      at hudson.model.Run.run(Run.java:1264)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:122)
      Caused by: hudson.util.IOException2: Cannot parse Results\Simian\simian-log.xml
      at hudson.plugins.violations.parse.AbstractTypeParser.parse(AbstractTypeParser.java:64)
      at hudson.plugins.violations.ViolationsCollector.doType(ViolationsCollector.java:189)
      at hudson.plugins.violations.ViolationsCollector.invoke(ViolationsCollector.java:116)
      at hudson.plugins.violations.ViolationsCollector.invoke(ViolationsCollector.java:27)
      at hudson.FilePath$FileCallableWrapper.call(FilePath.java:2028)
      at hudson.remoting.UserRequest.perform(UserRequest.java:114)
      at hudson.remoting.UserRequest.perform(UserRequest.java:48)
      at hudson.remoting.Request$2.run(Request.java:270)
      at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
      at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
      at java.util.concurrent.FutureTask.run(Unknown Source)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
      at hudson.remoting.Engine$1$1.run(Engine.java:58)
      at java.lang.Thread.run(Unknown Source)
      Caused by: org.xmlpull.v1.XmlPullParserException: characters ]]> are not allowed in content (position: END_TAG seen ...l].gFileSupport = ""\n resetemailstate()\n ]]>... @2714:20)
      at org.xmlpull.mxp1.MXParser.nextImpl(MXParser.java:1343)
      at org.xmlpull.mxp1.MXParser.next(MXParser.java:1093)
      at hudson.plugins.violations.parse.AbstractParser.endElement(AbstractParser.java:332)
      at hudson.plugins.violations.parse.AbstractParser.endElement(AbstractParser.java:328)
      at hudson.plugins.violations.parse.AbstractParser.skipTag(AbstractParser.java:228)
      at hudson.plugins.violations.parse.AbstractParser.skipToTag(AbstractParser.java:195)
      at hudson.plugins.violations.types.simian.SimianParser.parseSetElement(SimianParser.java:61)
      at hudson.plugins.violations.types.simian.SimianParser.execute(SimianParser.java:45)
      at hudson.plugins.violations.parse.AbstractTypeParser.parse(AbstractTypeParser.java:59)
      ... 14 more
      Email was triggered for: Failure

        Attachments

          Activity

          redsolo redsolo added a comment - - edited
          alexlombardi alexlombardi added a comment -

          That was the point I made: Simian recognizes that it is improper XML, and wraps it in a CDATA section, to make sure an XML parser doesn't read it. The plugin should not still treat it as proper XML considering it is identified as not being that.

          redsolo redsolo added a comment -

          Ok, i lack some XML expertise. But I did found this on the CDATA section "A CDATA section cannot contain the string "]]>". Nested CDATA sections are not allowed." at http://www.w3schools.com/xml/xml_cdata.asp

          redsolo redsolo added a comment -

          The issue is not with the Violations plugin but that the Simian tool outputs invalid XML. The current maintainer of the simian tool has fixed this problem and the latest version can be downloaded here http://www.harukizaemon.com/simian/


            People

            • Assignee:
              redsolo redsolo
              Reporter:
              alexlombardi alexlombardi
            • Votes:
              1 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: