Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-6943

Save config results in IOException: Unable to delete....config.xml when "Do not save duplicate history" is selected

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Labels:
      None
    • Environment:
      Hudson 1.365
      jobConfigHistory plugin 1.5
      Windows XP
      Apache Tomcat 5.5.29
    • Similar Issues:

      Description

      Saving a job configuration results in "HTTP Status 500 - java.io.IOException: Unable to delete C:\.hudson\jobs\example-project\config.xml" when "Do not save duplicate history" is selected.

      To reproduce: go to "Manage Hudson">"Configure System">"Job Config History"->"Advanced" and select the "Do not save duplicate history" box. All other configuration settings for the plugin can be the default values. The error occurs whether or not there are configuration changes, so just going to the config page of a job and clicking "Save" should result in this error.

      I'm surprised that no one else has come across this same problem, so I wonder if it's particular to my setup. I would investigate further, but I haven't got the time right now. Hopefully, someone can take a quick look and at least determine if the bug is reproducible.

      P.S. Thanks to Stephan and Mirko for the handy plugin. This will help clear up a lot of confusion about who changed what in job configurations.

        Attachments

          Issue Links

            Activity

            abarbieri Andrea Barbieri added a comment -
            sinkha sinkha added a comment -

            Thanks to abarbieri for pointing out the duplicate.

            cforce cforce added a comment -

            Same bug here!

            mfriedenhagen Mirko Friedenhagen added a comment -

            This is mostly a Windows-problem.

            mfriedenhagen Mirko Friedenhagen added a comment -

            Part of released version 1.9


              People

              • Assignee:
                mfriedenhagen Mirko Friedenhagen
                Reporter:
                sinkha sinkha
              • Votes:
                1 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: