Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-6996

In some browsers selenium crashes when the "other" field is left empty

    Details

    • Type: Patch
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: seleniumhq-plugin
    • Labels:
      None
    • Environment:
      Firefox/3.5.10, Debian sid
    • Similar Issues:

      Description

      When the "other" fild is left empty seleniumhq fails with the following error, at least with firefox:

      [workspace] $ java -jar /home/marco/Desktop/selenium-server-1.0.3/selenium-server.jar -htmlSuite *firefox http://localhost/ /home/marco/Desktop/testsuite.html /var/lib/hudson/jobs/ewsi/workspace/ewsi-svn/result.html
      unrecognized argument :
      Usage: java -jar selenium-server.jar [-interactive] [options]
      -port <nnnn>: the port number the selenium server should use
      (default 4444)
      -timeout <nnnn>: an integer number of seconds before we should give
      ...Publishing Selenium report...
      ERROR: Test reports were found but none of them are new. Did tests run?
      For example, /var/lib/hudson/jobs/ewsi/workspace/ewsi-svn/result.html is 39 min old

      Finished: FAILURE

      This is because the plugin just tests if the string with additional arguments is "null", and not if the string ist empty.
      The provided patch should fix this.

        Attachments

          Issue Links

            Activity

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in hudson
            User: : pascal_martin
            Path:
            trunk/hudson/plugins/seleniumhq/src/main/java/hudson/plugins/seleniumhq/SeleniumhqBuilder.java
            http://jenkins-ci.org/commit/32969
            Log:
            fix http://issues.jenkins-ci.org/browse/JENKINS-6996
            patch from Roman Fenkhuber

            pascal_martin pascal_martin added a comment -

            Patch apply in version 0.4, feadback apreciate.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: evernat
            Path:
            src/main/java/hudson/plugins/seleniumhq/SeleniumhqBuilder.java
            http://jenkins-ci.org/commit/seleniumhq-plugin/14026298112906d9bb670aa32872bd805fcf8dfa
            Log:
            fix https://issues.jenkins-ci.org/browse/JENKINS-7246 caused by patch in https://issues.jenkins-ci.org/browse/JENKINS-6996
            (do not use "this.getOther().isEmpty()", to be compatible with jdk 1.5)

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: evernat
            Path:
            src/main/java/hudson/plugins/seleniumhq/SeleniumhqBuilder.java
            http://jenkins-ci.org/commit/seleniumhq-plugin/e998f16c35c0650d1a0e56dbe404aac1a485fd9c
            Log:
            fix https://issues.jenkins-ci.org/browse/JENKINS-7246 caused by patch in https://issues.jenkins-ci.org/browse/JENKINS-6996
            (do not use "this.getOther().isEmpty()", to be compatible with jdk 1.5)


              People

              • Assignee:
                pascal_martin pascal_martin
                Reporter:
                amfortas amfortas
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: