Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-7446

CLONE -Gerrit stops sending verifications with the Hudson 1.375 release (1.373 works)

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: git-plugin
    • Labels:
      None
    • Environment:
      CentOS
    • Similar Issues:

      Description

      Hello,

      An RPM update of Hudson yesterday (to 1.375) prevents the gerrit trigger plugin from publishing the results of a build back to Gerrit. We downgraded hudson back to 1.373, and the problem went away. When the build starts, the "Starting build" message does make it to Gerrit, but though the build completes, Gerrit is not notified of the completion, and manual verification of the patch is required.

      Attached is what looks like the relevant hudson log portion. Please let me know if you need anything else.

      Thanks for a great plugin!

      Cheers,

      Bill Shupp

        Attachments

          Issue Links

            Activity

            Hide
            glundh glundh added a comment -

            The patch work great! Thanks, abayer! However, the GIT build action shows an empty bullet point. Is this supposed to happen? (Not sure if it is related to the patch)

            Screen attached.

            Show
            glundh glundh added a comment - The patch work great! Thanks, abayer! However, the GIT build action shows an empty bullet point. Is this supposed to happen? (Not sure if it is related to the patch) Screen attached.
            Hide
            glundh glundh added a comment - - edited

            File attached.

            Show
            glundh glundh added a comment - - edited File attached.
            Hide
            abayer Andrew Bayer added a comment -

            Lemme see if I can figure that out - I'm guessing that's a side effect of the "" key rather than null key.

            Show
            abayer Andrew Bayer added a comment - Lemme see if I can figure that out - I'm guessing that's a side effect of the "" key rather than null key.
            Hide
            abayer Andrew Bayer added a comment -

            Got it! It was exactly that - I've fixed it now for both BuildData displays - check for the next build after #24 at http://ci.hudson-labs.org/job/plugins_hudson-git-plugin/lastSuccessfulBuild/

            Show
            abayer Andrew Bayer added a comment - Got it! It was exactly that - I've fixed it now for both BuildData displays - check for the next build after #24 at http://ci.hudson-labs.org/job/plugins_hudson-git-plugin/lastSuccessfulBuild/
            Hide
            abayer Andrew Bayer added a comment -

            Resolved in 1.1.

            Show
            abayer Andrew Bayer added a comment - Resolved in 1.1.

              People

              • Assignee:
                rsandell rsandell
                Reporter:
                rsandell rsandell
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: