Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-7463

Support "Warning" tag on "Boost Test Library"

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Resolved (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: xunit-plugin
    • Labels:
      None
    • Environment:
      Windows 7
      Boost 1.37.0
    • Similar Issues:

      Description

      When converting the XML files I get the following error:

      [xUnit] [WARNING] - At line 1 of file:/d:/Workspaces/0902-win32-etk10/sci20/build/0902-win32-cpptests/test_Basis-win32.xml:cvc-complex-type.2.4.a: Invalid content was found starting with element 'Warning'. One of '

      {Info, Error, FatalError, Message, Exception, TestingTime}

      ' is expected.

      I'm guessing that the 'Warning' tag is a new tag in the "Boost Test Library" not available on "boost 1.35.0", which is the format supported by xUnit.

      I would like to either interpret and process the 'Warning' tag or at least ignore it so the other information are processed.

        Attachments

          Activity

          kaniabi Kaniabi added a comment -

          Looking further I found that the problem is in the DTKIT, more exactly in the file "boosttest-1.0.xsd".

          The file doesn't consider the "Warning" tag, and thus the error.

          kaniabi Kaniabi added a comment -

          The XSD file for boosttest-1.0 added the "Warning" tag.

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in hudson
          User: : gbois
          Path:
          trunk/hudson/dtkit/dtkit-default/dtkit-default-junit/src/main/java/com/thalesgroup/dtkit/junit/BoostTest.java
          trunk/hudson/dtkit/dtkit-default/dtkit-default-junit/src/main/resources/com/thalesgroup/dtkit/junit/boosttest-1.1.xsd
          http://jenkins-ci.org/commit/34863
          Log:
          Fixed JENKINS-7463

          gbois Gregory Boissinot added a comment - - edited

          The fix is available in trunk
          I'm going to include the fix in next release (1.9)
          You are able to test the fix by downloading the latest snapshot version (hpi file): http://ci.hudson-labs.org/job/plugins_xunit/31/org.jvnet.hudson.plugins$xunit/


            People

            • Assignee:
              gbois Gregory Boissinot
              Reporter:
              kaniabi Kaniabi
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: