Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-7579

NullPointerException in pmd analyzer

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: pmd-plugin
    • Labels:
      None
    • Similar Issues:

      Description

      5:40:04 [INFO] Generating "Dependency Convergence" report.
      15:40:06 [INFO] ------------------------------------------------------------------------
      15:40:06 [ERROR] FATAL ERROR
      15:40:06 [INFO] ------------------------------------------------------------------------
      15:40:06 [INFO] Name is null
      15:40:06 [INFO] ------------------------------------------------------------------------
      15:40:06 [INFO] Trace
      15:40:06 java.lang.NullPointerException: Name is null
      15:40:06 at java.lang.Enum.valueOf(Enum.java:195)
      15:40:06 at hudson.plugins.analysis.util.model.Priority.valueOf(Priority.java:18)
      15:40:06 at hudson.plugins.analysis.core.HealthAwareMavenReporter.getMinimumPriority(HealthAwareMavenReporter.java:465)
      15:40:06 at hudson.plugins.analysis.core.AbstractHealthDescriptor.<init>(AbstractHealthDescriptor.java:36)
      15:40:06 at hudson.plugins.pmd.PmdHealthDescriptor.<init>(PmdHealthDescriptor.java:25)
      15:40:06 at hudson.plugins.pmd.PmdResultAction.<init>(PmdResultAction.java:31)
      15:40:06 at hudson.plugins.pmd.MavenPmdResultAction.<init>(MavenPmdResultAction.java:57)
      15:40:06 at hudson.plugins.pmd.PmdReporter.persistResult(PmdReporter.java:94)
      15:40:06 at hudson.plugins.analysis.core.HealthAwareMavenReporter$1.call(HealthAwareMavenReporter.java:212)
      15:40:06 at hudson.plugins.analysis.core.HealthAwareMavenReporter$1.call(HealthAwareMavenReporter.java:210)
      15:40:06 at hudson.maven.MavenBuild$ProxyImpl.execute(MavenBuild.java:341)
      15:40:06 at sun.reflect.GeneratedMethodAccessor243.invoke(Unknown Source)
      15:40:06 at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      15:40:06 at java.lang.reflect.Method.invoke(Method.java:597)
      15:40:06 at hudson.model.Executor$1.call(Executor.java:402)
      15:40:06 at hudson.util.InterceptingProxy$1.invoke(InterceptingProxy.java:23)
      15:40:06 at $Proxy31.execute(Unknown Source)
      15:40:06 at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      15:40:06 at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      15:40:06 at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      15:40:06 at java.lang.reflect.Method.invoke(Method.java:597)
      15:40:06 at hudson.remoting.RemoteInvocationHandler$RPCRequest.perform(RemoteInvocationHandler.java:274)
      15:40:06 at hudson.remoting.RemoteInvocationHandler$RPCRequest.call(RemoteInvocationHandler.java:255)
      15:40:06 at hudson.remoting.RemoteInvocationHandler$RPCRequest.call(RemoteInvocationHandler.java:215)
      15:40:06 at hudson.remoting.UserRequest.perform(UserRequest.java:114)
      15:40:06 at hudson.remoting.UserRequest.perform(UserRequest.java:48)
      15:40:06 at hudson.remoting.Request$2.run(Request.java:270)
      15:40:06 at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
      15:40:06 at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
      15:40:06 at java.util.concurrent.FutureTask.run(FutureTask.java:138)
      15:40:06 at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
      15:40:06 at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      15:40:06 at java.lang.Thread.run(Thread.java:619)
      15:40:06 [INFO] ------------------------------------------------------------------------
      15:40:06 [INFO] Total time: 1 minute 5 seconds
      15:40:06 [INFO] Finished at: Mon Sep 27 15:40:06 CEST 2010
      15:40:07 [INFO] Final Memory: 108M/258M
      15:40:07 [INFO] ------------------------------------------------------------------------

        Attachments

          Activity

          evernat evernat added a comment -

          duplicate of JENKINS-6877


            People

            • Assignee:
              Unassigned
              Reporter:
              lucadistefano lucadistefano
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: