Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-7610

Workspace parameter expansion does not work on slaves

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      The workspace name parameter expansion (see JENKINS-7011) does not work for polling on slaves.
      For polling on master the log says something like "Using master client hudson-jobname", but for polling that takes place on a slave it says "Using remote client hudson-${JOB_NAME}".
      Builds work fine, but it constantly triggers new builds for no reason.

        Attachments

          Activity

          Hide
          rpetti Rob Petti added a comment -

          We've got 3 issues open for this one already (I closed one as a dupe not too long ago), but this is the first one that actually supplies useful information. Now I actually know how to reproduce it, and where the problem might be.

          Show
          rpetti Rob Petti added a comment - We've got 3 issues open for this one already (I closed one as a dupe not too long ago), but this is the first one that actually supplies useful information. Now I actually know how to reproduce it, and where the problem might be.
          Hide
          torbent torbent added a comment -

          Ooh, that's nice
          I searched for existing issues first but didn't find any that matched (in my eyes) ...
          I can copy the actual polling log into here if that would help even more?

          Show
          torbent torbent added a comment - Ooh, that's nice I searched for existing issues first but didn't find any that matched (in my eyes) ... I can copy the actual polling log into here if that would help even more?
          Hide
          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in hudson
          User: : rpetti
          Path:
          trunk/hudson/plugins/perforce/src/main/java/hudson/plugins/perforce/PerforceSCM.java
          http://jenkins-ci.org/commit/35373
          Log:
          [FIXED JENKINS-7610] fixed issue when polling on slaves with client name substitutions

          Show
          scm_issue_link SCM/JIRA link daemon added a comment - Code changed in hudson User: : rpetti Path: trunk/hudson/plugins/perforce/src/main/java/hudson/plugins/perforce/PerforceSCM.java http://jenkins-ci.org/commit/35373 Log: [FIXED JENKINS-7610] fixed issue when polling on slaves with client name substitutions
          Hide
          rpetti Rob Petti added a comment -

          If you want, though I think I just fixed it. I'll run a release today if nothing else major comes up.

          Show
          rpetti Rob Petti added a comment - If you want, though I think I just fixed it. I'll run a release today if nothing else major comes up.
          Hide
          torbent torbent added a comment -

          Fix works.

          Show
          torbent torbent added a comment - Fix works.

            People

            • Assignee:
              rpetti Rob Petti
              Reporter:
              torbent torbent
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: